swaptunes help

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

flthnasty

New Member
Oct 26, 2007
7
0
0
#1
I'm having problems with swaptunes all of a sudden. It worked fine at first, but now one of my libraries won't play. Does anyone know why this is, or have any suggestions.
 

bobby337

New Member
Jul 7, 2007
4
0
0
#2
re

Got the same problem. Only one of my library is playing, when i swap to the other it shows the same songs as the first library but will not play any songs.
I haven't uninstalled swaptunes yet, just thought there might be a quicker way. thank you.

update, tried uninstalling swaptunes still doesn't work.
Going to try BSD subsystem next.
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#3
Got the same problem. Only one of my library is playing, when i swap to the other it shows the same songs as the first library but will not play any songs.
I haven't uninstalled swaptunes yet, just thought there might be a quicker way. thank you.

update, tried uninstalling swaptunes still doesn't work.
Going to try BSD subsystem next.
I use SwapTunes a lot, and I have noticed a few quirks which aren't directly related to the app, but it does reveal a few things about your iPhone.

1) If you cannot swap libraries from the offset, you may need to soft reset your phone first and then try again. If this is the case your jailbreak is a little touchy, and the write permissions aren't "sticking" when it comes to applications such as this. A clean JB'd phone can swap without any problems. Another way to test this is to install SSHKit and try turning off SSH. If it snaps back "on" or "off" after trying to change it, your iPhone is definitely in for some headaches in the future.

2) Open up Mobile Finder and browse to /var/root/media/ and see if you have "iTunes_Control_2" which is basically the other library you're swapping to. If you see it, but it has no information in there, copy over the "iTunes" folder from within the "iTunes_Control" folder (the workign one). Make sure to swap to that new library so its active and try to sync. You'll get a warning from iTunes saying it will need to delete the data and resync. At this point you're golden. Now, you can swap libraries and sync without issue no matter which library your'e using.
 

bobby337

New Member
Jul 7, 2007
4
0
0
#4
I use SwapTunes a lot, and I have noticed a few quirks which aren't directly related to the app, but it does reveal a few things about your iPhone.

1) If you cannot swap libraries from the offset, you may need to soft reset your phone first and then try again. If this is the case your jailbreak is a little touchy, and the write permissions aren't "sticking" when it comes to applications such as this. A clean JB'd phone can swap without any problems. Another way to test this is to install SSHKit and try turning off SSH. If it snaps back "on" or "off" after trying to change it, your iPhone is definitely in for some headaches in the future.

2) Open up Mobile Finder and browse to /var/root/media/ and see if you have "iTunes_Control_2" which is basically the other library you're swapping to. If you see it, but it has no information in there, copy over the "iTunes" folder from within the "iTunes_Control" folder (the workign one). Make sure to swap to that new library so its active and try to sync. You'll get a warning from iTunes saying it will need to delete the data and resync. At this point you're golden. Now, you can swap libraries and sync without issue no matter which library your'e using.


Ok I tried a bunch of stuff to get this working so I'm not sure what I did that fix it or if it even fixed since I still haven't sync to my second computer yet to test everything out.

First I uninstalled itoggle because when I change the SSH setting in SERVICES it doesn't seem to change it in itoggle. I should of use only itoggle anyways instead of SERVICES but since I install itoggle last I figured that the newer program was causing the problem.
Second, I had my iTunes sync to "sync only checked songs and videos" before, so I went into Music tab and checked the "All songs and playlists"
After that I click Sync, then the pop up window about will erase and data.

After that it is done loading all of the songs again, everything is working fine now.
 

x999x

New Member
Gold
Aug 6, 2007
1,656
0
0
#5
Haha, yeah its a bit of a tricky program to use when it doesn't want to work correctly.

I have to admit, I ran into problems very similar to yours, and the tell-tale sign was that I could not switch SSH off. I could sit there for a few seconds and watch the switch turn back to whatever it was previously which was very annoying.

A simple restore and re-jailbreak fixed it right up to where SwapTunes worked on the first try, and turning SSH off from the Services App works as it should. I don't mean to scare you, because your phone may be perfect and not require any further attention, just want to throw out food for thought incase you run into more problems down the line not related to SwapTunes, but that darned "Toggle" problem.