Sync with iCal

jscottbarnes

New Member
Jun 29, 2007
11
0
0
DC Metro
I have been using MobileMe to sync with iCal for a couple of months now... I have imported a few sports calendars to monitor my fav teams gamenights, and they show up fine....

All of a sudden, (maybe not suddenly) when I enter a new item into iCal... it doesn't show up in MobileMe or on the iPhone... (I have a few different calendars set up in iCal [home-Cowboys-Tarheels]), but just tried to add an appt directly to my Home calendar, and it doesn't sync to iPhone or MobileMe...

Any suggestions/advice...
 

sujitsumitran

New Member
Mar 17, 2009
3
0
0
I've tried everything that's been posted here including resetting the iSync history. I have an Intel MacBook and a First Generation iPhone. Help!
 

krayzee

New Member
Dec 26, 2009
1
0
0
I had the same problem and this fixed it.

1. Go to iTunes and select your phone.
2. Uncheck sync calendar.
3. Sync Phone
4. Select sync calendar then select "selected calendars"
5. Select all of the calendars you need.
6. Go to bottom in Advanced section select replace calendar.
7. Sync Phone

Everything synced fine from phone to machine and from machine back to phone after this. Apparently iCal generates some bogus calendar if you select "all calendars".

Good luck!
I've tried this one a couple times, with the same problem (can't get iCal to sync onto ipod touch, not iPhone) but it doesn't even load it. iTunes says it's syncing and so does my iPod touch, but even after half an hour it won't be done syncing. I really don't have that much, either. Just a few things.

Any ideas?
 

droodles

New Member
Sep 22, 2010
3
0
0
I am having a similar problem.

I have an iPhone 4, a Macbook, and am not using MobileMe. When I create an event in the calendar on the Macbook, it appears on the iPhone when I sync the two, no problem. When I create an event on the iPhone calendar, however, it does not appear on my Macbook calendar, no matter how many times I sync it.

I've tried un-sync-ing the two, and only syncing selected calendars, but that doesn't solve the problem.

Can anyone help?

Thanks!
 

Jack06

Member
Bronze
Jan 6, 2009
122
0
16
I'm pretty sure, unless you physically sync your iPhone to your Mac via a USB cable it won't sync automatically, unless your using mobile me.....
 

The Don Yebisu

New Member
Jul 1, 2011
1
0
1
Had to make an account to post this.

Basically I was experiencing a problem similar to many users: I would create an event on my iPhone and try to sync with my MacBook with no success. However, events in iCal on my MacBook would successfuly be copied to the calendar on my iPhone.

Solution: After syncing via iTunes, go into the calendar on your iDevice and edit the event - you'll see that you can now choose a calendar from the 'From My Mac' list, as opposed to either A) some generic calendar, or B) a calendar that is tied to e.g. your G-mail account (this was my problem). After you've chosen a calendar from that list for each event you want synced, go ahead and sync again in iTunes. Should be squared away!

While it is a pain to edit each event individually, it seems the only way. If you've got more than a dozen events or so, it might be easier to input the events in iCal on your mac, and then sync again. You can hide the generic/G-mail calendar (assuming you don't want to use it) if seeing double events on your iDevice for a few weeks is too bothersome.

Oh, and from now on when creating events on your iDevice, don't forget to specify which calendar a given event should be classified under (should be a calendar you keep on your mac in iCal)!

Hope this helps.
 

jessicalouize

New Member
Feb 22, 2012
1
0
1
I also had to create an account: @The Don Yebisu, et all:

*Quick answer: iCal doesn't recognize Gmail calendar -- change your default calendar on your iPhone settings to a My Mac calendar instead. (also, using "All Calendars" vs. "Selected Calendars" does not make a difference in this recognition, as a previous person suggested-- er, that I could tell in my incredibly long and wasteful trial and error session.)

*Long Answer:
I too had problems syncing back and forth: events created on my Mac in iCal would sync to iPhone but not vice versa. Basically what was happening is that when I created events in my iPhone cal it automatically selected "gmail calendar" option (versus a My Mac calendar, or a iCloud or any other calendar). Because it automatically selected "Gmail" calendar option, it wouldn't sync to/appear on after syncing with my Mac/iCal. I don't know why iCal on mac won't recognize Gmail calendar, but it won't. I don't know that I NEED Gmail Calendar at all (except all the past events that are now labeled as Gmail and only in iPhone that I don't want to get rid of).

The Don specified that you should select which calendar you want to save as (instead of allowing this default calendar that your mac won't recognize)-- while this is true, you can alternately (and more easily) change your default calendar by going to Settings>Mail,Contacts,Calendar (then scroll down to Calendar) and tap "Default Calendar". It will show you your calendar options. I have now selected the vaguest description I set as the first cal option "Stuff" for my default (this means when i create an event on my iPhone cal and don't change the calendar setting, it will by default be labeled as "stuff," and since it is a My Mac calendar, it will also be 'allowed' to sync back to my mac (unlike the Gmail cal)). Now that Gmail is no longer the default, you should have no problems syncing back and forth----

I fear this really only solves one's problem if they don't' give a crap about Gmail calendar. I don't know why iCal on my mac doesn't recognize the Gmail calendar, but unless I forgot or missed one of my trial and error steps in all this madness, I don't think it does. Personally I have no use for any calendars outside of my iCal on my mac and my iPhone. As long as they sync (manually as it may be) back and forth, I'm happy. Frankly, there are too many options for me in this technological world: I don't need an iCloud AND Gmail ANd mac cal to keep me organized-- that is just tooooo confusing! (I tried to consolidate and make this as readable as possible... hope it helps!)