Text message not working

Margara

New Member
Nov 7, 2011
3
0
1
#1
Hi Guys
Any one can tell me why my text message is not working after baking up my my New iPhone 4 ( latest versión of iTunes and iSO5 )
 

verwon

Evangelist
Gold
Jul 29, 2011
1,015
121
63
Seattle
#2
Are you getting an error? If so, what error?

Have you refreshed your carrier network settings?


Sent from my iOS ecosystem!
 

Margara

New Member
Nov 7, 2011
3
0
1
#3
If i try and write a txt it just closes the app when i hit send. I can only half receive a txt - i have the senders ñame in inbox but no actual message. Also at top of inbox it says messages(-1) which is weird. This is second New phone O2 have given after first one had same problem. We even checked it in store and it sent texts ok but as soon as i "backed up" all my contacts etc it seemed to get "infected" with the same problem.?
Thanks so much for any advice I don't want to have the hassle of sending this one back only for same prob to happen again.
 

RoofMonkey

Genius
Gold
Jun 21, 2010
8,861
2,046
113
Florida
#4
Have you turned the device off, then back on again or done a hard reset?
Press and hold home and sleep button together, ignore the slide to power off just keep holding them down until you see the Apple logo. Then release both at the same time. No data will be lost, this is just a complete shutdown / estate of the device.
Give that a try and see if that helps.
 

coop1701

Zealot
Silver
Jun 30, 2007
899
114
43
#6
I think Baking your iPhone 4S voids the warranty. But I could be wrong.

Usually rebooting will solve a network error with your carrier.
 

Margara

New Member
Nov 7, 2011
3
0
1
#7
Thanks Guys
We've done all the usual steps from soft restore, different sim, hard restore to factory settings all the way to giving it back to store new one.

So it's gotta be something to do with my oven, I mean computer and back up of the previous iPhone 3GS I'm syncing the new 4 to?

Free bread recipe to the first one to solve this one for us :)
 

RoofMonkey

Genius
Gold
Jun 21, 2010
8,861
2,046
113
Florida
#8
Thanks Guys
We've done all the usual steps from soft restore, different sim, hard restore to factory settings all the way to giving it back to store new one.

So it's gotta be something to do with my oven, I mean computer and back up of the previous iPhone 3GS I'm syncing the new 4 to?

Free bread recipe to the first one to solve this one for us :)
Instead of doing a restore from backup try setting it up as new.
 

rambo47

Contributor
Silver
Apr 4, 2010
528
79
28
Northern NJ
#9
I would pop the SIM card out and then put it back in. You won't lose any data but connectivity will be refreshed. Then check with AT&T to make sure your plan is properly provisioned. If AT&T screwed the pooch no amount of tinkering with the phone will set it right.