Trouble downgrading from 1.1.2 to 1.1.1

blacklabel775

Member
Bronze
Jul 5, 2007
62
0
6
#1
Well, i decided to update to 1.1.2 and try to jailbreak using the oktoprep and dev team 1.1.2 jailbreak, but i could not get it to work properly.

So, now i have unmodified 1.1.2 on my phone and I am having trouble when i try to downgrade back to 1.1.1.

I use the "option-click" restore method and select the 1.1.1 restore file, which downgrades the firmware and gives me the 'standard' downgrade error message. Then i run AppTapp to coerce iTunes into recognizing the phone like i had done when downgrading from 1.1.1 to 1.0.2, and things seem good, except that my phone will not activate. I can get onto the phone to use the internet (wi-fi) and other applications, but there are no service bars and no ATT carrier logo, and no calls will go through. I have never tried to unlock to iPhone to use on different carriers or anything, so i have no idea why my phone wont activate.

Anyone have any insight into what i can do to fix this?
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#2
This is a known problem to those who updated to 1.1.2, and have reverted to 1.1.1: the phone won't work.

You will either need to get 1.1.2 jailbroken (I did it without issue) or downgrade the baseband in order to use your iPhone as a phone.

Here is a tut on how to revert back from 1.1.2:
http://www.modmyi.com/forums/showthread.php?t=15495


--
Mike
 

brianhyp

New Member
Bronze
Jun 6, 2007
118
0
0
44
#3
thank you I now have a jailbroken 1.1.2 phone from 1.1.2 on windows!
okay they released jailbreak for 1.1.2 but to do so you have to downgrade to 1.1.1 and download the okie prep package. problem was to downgrade you need independence (MAC PROGRAM) . I have windows so I used app tapp instead and the same thing happeneded (no cell phone sevice). i used my wi fi to jailbreak (jailbreak me.com) added the okie prep package then updated to 1.1.2 this fixed the no cell service then used the new jailbreak and wala jailbroken 1.1.2 phone on windows from 1.1.2
 

Hi-Phone

New Member
Jul 5, 2007
104
0
0
#4
This is a known problem to those who updated to 1.1.2, and have reverted to 1.1.1: the phone won't work.

You will either need to get 1.1.2 jailbroken (I did it without issue) or downgrade the baseband in order to use your iPhone as a phone.

Here is a tut on how to revert back from 1.1.2:
http://www.modmyi.com/forums/showthread.php?t=15495

Hi Tinman! kudos to everyone you helped along the way here on this forum. I read that you finally did the update firmware from 1.02. (if im correct) did you do the jailbreak on the 1.1.2? or did you have to jailbreak before hand? i read the tutorial on how to downgrade the 1.1.2 to the 1.1.1 but the tuturial was a but sloppy and could not understand fully. is there a way to explain it all in simple terms? thanks in advance!
 

blacklabel775

Member
Bronze
Jul 5, 2007
62
0
6
#5
Thankyou for the help, but things have gone from not so good to pretty bad.

Since I had updated to 1.1.2, i need to downgrade to 1.1.1 to download the 1.1.2 jailbreak prep application. When i originally posted, i could use AppTapp to get the phone to show up in iTunes, and i could get onto wi-fi networks.

Since then (only a few hours) i can no longer use AppTapp to get iTunes to recognize the phone. When i run app tap, it runs for a few seconds before it force quits itself (i am on Mac OSX Leopard). I was planning on trying to jailbreak 1.1.2 again when i got home, but not i cant get back to 1.1.1 at all.

While trying to fix the original problem i uprgaded to iTunes 7.5 from 7.4.2, but when the issue still wasn't fixed i went back to 7.4.2, i wonder if this had anything to do with it.

Any suggestions?