trouble with iMessages/text messages

Discussion in 'iPhone 4' started by haras.backwards, Aug 28, 2012.

  1. haras.backwards

    haras.backwards New Member

    Joined:
    Aug 28, 2012
    Likes Received:
    0
    This has happened with two of my contacts now, both of them and I have the latest software on our iPhones (their's are iPhone 4S' and mine is an iPhone 4):
    text messages were working as normal, blue windows representing iMessages then messages started going through as green 'sent as text message' but were not being received on the other end Only when I replied to the messages trail between us.
    I can get the other people to receive my messages if i start each text to them as a new message and select their name from the contacts list instead of replying to their message. Their replies come through in a different message trail so I have one lot of messages under that contact name which are all received and one lot saved separately which are all sent. I noticed with the second contact this happened immediately after he got a new iPhone 4s.

    Any clues would be very appreciated. it is inconvenient and gives no warning or indication that it is happening.
     
  2. Girdler

    Girdler Contributor
    Bronze

    Joined:
    Aug 1, 2012
    Likes Received:
    44
    First, obviously, make sure that iMessage is still turned on. Settings > Messages > iMessage toggle.

    Then, I would advise trying to reset your network settings(you can toggle airplane mode first to test too).

    Settings > Airplane Mode.

    Settings > General > Reset > Reset Network Settings.

    If that does not work, try a hard reset on the device(holding the home + sleep/wake button until the screen goes black and the Apple reappears).

    Still unsuccessful, attempt restoring as new.
     
  3. fury

    fury Evangelist
    Gold

    Joined:
    Oct 23, 2007
    Likes Received:
    238
    I would suggest both ends turn off "Send as SMS" in messages settings. Then, if an iMessage fails or is delayed for any reason (poor signal, slow network connection, etc), it does not automatically fall back to SMS. I've found that iMessage's threshold for "giving up" and going to SMS is a little too easy to hit. That is particularly problematic if the text it sends costs you money (international, or no text plan, or whatever)

    Even with this option enabled, you can still converse over normal SMS with contacts that don't have iMessage, it just won't switch back to SMS if you sent it as an iMessage.

    Only other thing I can think of is to make sure you have them set up as a contact using the exact email or phone number they've registered to iMessage, country code and all. i.e. if their iMessage settings say "Receive at +1 (555) 555-1212" then make sure your contact phone number for them is also +1 (555) 555-1212. Or start using emails for iMessage if you're not already.
     
  4. Jonathan Smith

    Jonathan Smith New Member

    Joined:
    Jan 25, 2013
    Likes Received:
    0
    Have you tried restoring your phone?
     

Share This Page