Unable to activate Predictive Text

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

galaxyman

New Member
Aug 17, 2014
9
1
3
#1
Hi all, I am unable to activate predictive text using Apple's stock keyboard (english UK). Each time I hit the globe icon the predictive text icon is off unable to be clicked on to green, please see screen shot. In settings I have predictive text icon on (green). I have a 5s running iOS8.1. I also have swype installed. How do I turn predictive text ON for the Apple keyboard? Thanks for any help.
ImageUploadedByiCafe Forums1416223998.040564.jpg
 

Nrevezzo

Member
Bronze
Apr 15, 2009
104
23
18
Canton, Mi
#2
Try going to settings -> general - > keyboards and turn on predictive. If it's already on then turn off then on again. I had a problem previously where predictive text stopped working and turning it off then on restored it.
 

Sharunda

Genius
Gold
Jun 16, 2008
4,987
1,085
113
One Horse Town, New Jersey
#4
Try going to settings -> general - > keyboards and turn on predictive. If it's already on then turn off then on again. I had a problem previously where predictive text stopped working and turning it off then on restored it.
I love the predictive text. After this last update it stopped working. I just did what you said. I went in to General - Keyboards and cut it off then back on and now it's working again. YAY!

Duh I didn't think of this myself. Thanks


Sent using iCafe app
 

galaxyman

New Member
Aug 17, 2014
9
1
3
#5
No I have tried again and still not working, in settings I toggled predictive text to off, and back on again but when typing in messages or email etc predictive text is not always available!!!
 

Sharunda

Genius
Gold
Jun 16, 2008
4,987
1,085
113
One Horse Town, New Jersey
#6
No I have tried again and still not working, in settings I toggled predictive text to off, and back on again but when typing in messages or email etc predictive text is not always available!!!
Try to do a hard reset and if it doesn't come right back when he iPhone restarts, go into the Keyboard and deselect (if Predictive text is still selected) and then reselect it again. If it's not selected, select it and see if this corrects the issue. Maybe a hard reset will help.
 

galaxyman

New Member
Aug 17, 2014
9
1
3
#7
Hi Sharunda, no joy I'm afraid, did a hard reset like you suggest but predictive toggle will not stay green, oh well I'll keep using Swype, at least its consistent, usually!! thanks.
 

RBNetEngr

Contributor
Bronze
Jun 17, 2013
170
27
28
#8
Galaxyman, I think I figured out what's going on. You have the predictive text bar hidden.

If you see a short bar above the 'T' and 'V' keys, like this:

ImageUploadedByiCafe Forums1416535738.662540.jpg


That's the predictive text bar being hidden. At that point, you can touch the bar and sweep up, and it will open the predictive text bar up.

ImageUploadedByiCafe Forums1416535833.105391.jpg


Interestingly, before I captured these screen shots, if I pressed and held the emoticon key the predictive text toggle was off and grayed out, whether the predictive text bar was visible or not. But now, the toggle switch is green whether the predictive text bar is visible or not.

ImageUploadedByiCafe Forums1416535946.832089.jpg


I suspect that this may be something that Apple slipped into one of the recent updates. It was non-intuitive to hide the predictive text bar by sliding it down. Nothing indicated that it was possible. By adding the toggle, it is more intuitive, although pressing and holding the emoticon key to have the toggle switch be visible is also non-intuitive. Perhaps if you have third party keyboards installed you know about switching between keyboards by using the emoticon key, but the average user won't know that.

You may also want to try removing any third party keyboards to see if they are interfering with predictive text on the standard keyboard.

Hope this helps!

-rb
 
Last edited:

galaxyman

New Member
Aug 17, 2014
9
1
3
#9
Hi RBNetEngr thanks for your detailed response. I uninstalled Swype and tried a text again, seems like it's nothing to do with the third party app but myself, yes my stupid self!! If you noticed my very first screen shot showed no address in the To: field, after your response I tried adding an address in the To: field first and predictive text became available. Seems like I've wasted alot of people's time due to my ignorance. Sorry yo you but thanks at the same time.
ImageUploadedByiCafe Forums1416598776.076819.jpg