Unable to turn on keychain in icloud preferences

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Valen85

New Member
Nov 11, 2015
2
0
1
#1
Using iMac 10.6 and fully upgraded.

Mac Mail was unable to connect because of a bad username/password.

1. I double checked and re-entered my username and password, still had issue
2. Went to icloud.com and verified the username/password was correct, and it was good
3. I then decided to uncheck KeyChain from iCloud in System Preferences

But that didn't work and now whenever I open mac mail i get a popup saying I need to activate KeyChain in iCloud.

So I went to iCloud in System preferences to check KeyChain, I enter username/password and it comes up as invalid but I do get a passcode to enter from my phone but it wont get to that part as its saying that I'm entering incorrect username/password even though they are correct.

Is there any ideas that can help me with this, it is very frustrating.
 

Valen85

New Member
Nov 11, 2015
2
0
1
#2
Well i had just figured it out but don't delete just incase another person has this issue.

I resolved it by removing 2step verification, after that the username/password wasn't seen as incorrect and Keychain was able to be checked in iCloud.