Unlock iPhone, WiFi stopped working

hetul

New Member
Dec 10, 2007
6
0
0
#1
Hello,

I have an unlock iPhone.

Firmware: 1.0.2 (1C28)
Modem Firmware: 04.01.13_G

My wifi worked fine for a few weeks before it died... now, it would just not detect the available network. I have tried to use it with different routers at different locations but it would just fail to detect them!

I had it working nicely without any issues for some weeks. Not sure what caused the issue.

What should i do to get it working?
  1. Should i try and Restore the phone with 1.1.1 firmware?
  2. If i do that, and the wifi still doesn't work, is there a way to unlock the iPhone using USB cable?
  3. Is there any other way to troubleshoot this issue?
Any assistance in this matter would be highly appreciated.

TIA
hk
 

akimoto

New Member
Dec 10, 2007
2
0
0
#2
broken wifi

I'm in a similar situation.

I had an unlocked iPhone

Firmware: 1.1.1
Modem Firmware: 04.01.13_G

Wifi worked for 3 weeks, then got progressively worse. To the point where I couldn't use it all. I was extremely frustrated at this point. Multiple attempts were made to get the iPhone to connect to various routers (changed router channels. all types of encryption as well as no encryption).

---

Yesterday, I tried to fix the problem by connecting my iPhone and restoring it back to Firmware 1.1.1

Restore went well, then attempted to bypass activation and unlock the phone (using the method I used originally "unlock.no"), but I couldn't complete the process because I don't have wifi!

Now I'm stuck. I can't get past the activation. I've been searching for an alternative to unlock via USB.

Hopefully there is someone here that has some experience with this type of problem. I've been searching and this broken wifi issue has affected others.
 

hetul

New Member
Dec 10, 2007
6
0
0
#3
I'm in a similar situation.

I had an unlocked iPhone

Firmware: 1.1.1
Modem Firmware: 04.01.13_G

Wifi worked for 3 weeks, then got progressively worse. To the point where I couldn't use it all. I was extremely frustrated at this point. Multiple attempts were made to get the iPhone to connect to various routers (changed router channels. all types of encryption as well as no encryption).

---

Yesterday, I tried to fix the problem by connecting my iPhone and restoring it back to Firmware 1.1.1

Restore went well, then attempted to bypass activation and unlock the phone (using the method I used originally "unlock.no"), but I couldn't complete the process because I don't have wifi!

Now I'm stuck. I can't get past the activation. I've been searching for an alternative to unlock via USB.

Hopefully there is someone here that has some experience with this type of problem. I've been searching and this broken wifi issue has affected others.

did you try to virginize the phone before restoring? I have no clue if that would work... but something you can try...

I was tempted to try and use the restore option and upgrade to 1.1.1 but am not too confident after hearing your story..

will wait for someone to throw some light on this issue.
 

hetul

New Member
Dec 10, 2007
6
0
0
#4
Akimoto,

I found this on another forum:

Here ya go:

Pakal and I followed this tip but since the phone was not unlocked ever, we ierased the baseband then simply restored and voila...

Credit to Citrus for this....

OK, everyone who has done any sort of hacking, flashing, restoring etc. and ended up with an iBrick with the following symptoms:

IMEI: Unknown ICCID: Unknown, Rapair Needed (iPhone cannot make or receive calls), no audio (except headset), no [COLOR=#006400 ! important][FONT=Lucida Grande,Lucida,Verdana,sans-serif][COLOR=#006400 ! important][FONT=Lucida Grande,Lucida,Verdana,sans-serif]WIFI[/FONT][/FONT][/COLOR][/COLOR] i.e. corrupt baseband or baseband flash is in a limbo state and cannot communicate with ieraser or bbupdater, then the following solution MAY resolve your issue. I did this on a 1.1.1 iPhone which I had hacked a dozen times and had gone from 1.1.1 to 1.0.2 and back and forth etc, because of the above symtoms, until I discovered a very easy way to resolve the problem. After all it's only software, thus I don't believe it's possible to damage your iPhone permanently by just the software and baseband tinkering. I recommend you read this entire procedure to understand what is being done, prior to diving into it. Read each step BEFORE attempting it, so you can follow the procedure exactly as it is written and avoid possible mistakes. We will do everything via Mobile Terminal on the iPhone, since your WIFI does not work due to the corrupt baseband.

I have [COLOR=#006400 ! important][FONT=Lucida Grande,Lucida,Verdana,sans-serif][COLOR=#006400 ! important][FONT=Lucida Grande,Lucida,Verdana,sans-serif]Macs[/FONT][/FONT][/COLOR][/COLOR] and an XP machine and yet to my surprise, I found this solution to work extremely quick and easy with Windows. Due to the condition my iPhone was in, iNdependence and various other activation apps could not activate my iPhone because my ICCID was unknown. So, I used a Windows laptop and it worked, with PAYCAY! Please note, I did all this without a SIM card in my iPhone, until I fixed it and then inserted my SIM card
. In all the procedures, the various apps will ask you to reboot your iPhone, sometimes several times, it is OK!

You need to download the following tools: AppTappInstaller.exe, PACAY and iBrickr_0.91.

Also download the following files: ieraser, bbupdater, secpack, ICE03.14.08_G.eep and ICE03_14_08.fls

1. Get your iPhone to 1.0.2, if you are already at 1.0.2 with the yellow attention triangle on your iPhone screen, go to step 2. If you have the cable with the iTunes logo on your screen, it means you are at 1.1.1 and perhaps don't know what to do. Connect your powered on iPhone to iTunes, click away any message iTunes displays about your phone and make sure your phone is recognized by iTunes. Now hold both home and power/sleep button for 10 seconds, then release only the power/sleep button. While still holding the home button, you are waiting for iTunes to pop up a window telling you it has found your iPhone to be in recovery/restore mode. As soon as it does, let go the home button. Your iPhone screen should be blank (black). If you are seeing the iTunes logo and the cable connect again, then you will have to repeat the previous instruction.

2. Your phone has the yellow triangle (this means your at 1.0.2). Now connect your phone to your XP machine and run AppTappInstaller.exe. The first time it will fail, close AppTapp then start iTunes until you get an error message from iTunes then close iTunes again, including the iTunes Helper process. Now run AppTappInstaller.exe for a second time and wait until it is finished, it should run to the end with a success message. Go to step 3.

3. If you downloaded PAYCAY and unzipped it, you should have a "MACOSX" folder and a "YouTube (Windows) fix" folder. Open the Windows folder and double click on "(CLICK HERE) activate.bat". Follow the instruction to reboot your phone. You should now have an activated iPhone at version 1.0.2, go to step 4.

4. Start iBrickr and go to Applications, follow the instructions to install applications. After rebooting you phone several times, you should now be able to install apps. Browse for the following apps and install them: "BSD Subsystem", "UIctl" (by Nate True) (or use Launch Gui by Erica Sadun same thing) and "Mobile Terminal VT100". Make sure these are installed, you can verify by refreshing the app list in iBrickr. On your iPhone go to your home screen and see if the 2 apps, UIctl and Terminal are installed. Sometimes I had to install the apps 2 or 3 times, until they actually were installed. Now copy the following files to the /usr/bin/ directory on your iPhone: ieraser, bbupdater, secpack, ICE03.14.08_G.eep and ICE03.14.08.fls. Go to step 5.

5. Tap the Terminal in your home screen. You will see a command line. Type the following commands followed by enter: chmod +x bbupdater
chmod +x ieraser
chmod +x secpack
chmod +x *.fls
chmod +x *.eep

Now press your home button and go back home, tap the UIctl icon. CAUTION, do not play around with the services by stopping or unloading them without knowing the affect. You need to tap on only the following services:

Tap on com.apple.CommCenter - you will be given several choices, just tap "unload -w"
then tap on com.apple.mobile.lockdown - again you will be given several choices, just tap on "stop" and go to step 6.

6. Now go back into Terminal and type "ieraser" in the command line and watch the magic happen.
Now type bbupdater -f *.fls -e *.eep and watch how the firmware will be loaded into the flash.

7. You should now be able to have all your hardware working again, just need to unlock using your choice of app.
 
Dec 17, 2007
26
0
0
#8
Help!, I followed this thread word for word, and got all the way up to where you have to input the Commands. So I put the files on the phone, and then type into terminal... chmod +xbbupdater
and so on for ieraser, secpack, *.eep, and *.fls or whatever it is... now they command either would say "usage: chmod [-R [-H | -L] -P]] mode file"
for all of them or it would say "chmod: ieraser: No Such file or directory"

Can anybody tell me what the heck is going on, If im not doing something right or what not or if these should be typed in a certain way...? Please people i've been trying everything I could think of all night long I just want this iPhone to work again,

btw...its been unlocked before (1.1.1) but then got the no WiFi problem so thats why I started all over again.
Thanks!
 
Dec 17, 2007
26
0
0
#9
Help anybody pleaseeee lol? I'm so lost it's not even funny! I have 2 brand new OTB 1.1.2's that are pretty much paperweights until they can be unlocked and this 1.1.1 OTB phone I HAD unlocked and working, got BRICKED! GREAT, just my luck. So now I'm trying to unbrick it, and so far I have it at 1.0.2 Firmware, it has no Wifi, and cant get any...and its got the 04.02.13 version. So people what do I do next? Since I can't connect to Wifi i have no IP address. And I tried this method posted, where you load all those files individually BUT, I go to terminal to start using them and it says permission denied and stuff...what the heck?

Somebody, anybody help is needed, if I can't get this one unbricked and running then I have a THIRD paperweight! :|

Thanks.
 
Dec 17, 2007
26
0
0
#10
well, got past what i was stuck at now im just stuck on why its not getting any farther than this error... i put in all the commands properly and it comes up with .fls cannot be updated or something...the .eep one went fine but the .fls had troubles and my baseband is STILL at 04.02.13, with the 3.9 bootloader, and 4.0.2 firmware, and NO Wifi! Anybody have any suggestions?
 

alflairdo

New Member
Nov 7, 2007
2
0
0
#11
[trueblue204 Help!, I followed this thread word for word, and got all the way up to where you have to input the Commands. So I put the files on the phone, and then type into terminal... chmod +xbbupdater
and so on for ieraser, secpack, *.eep, and *.fls or whatever it is... now they command either would say "usage: chmod [-R [-H | -L] -P]] mode file"
for all of them or it would say "chmod: ieraser: No Such file or directory"

Can anybody tell me what the heck is going on, If im not doing something right or what not or if these should be typed in a certain way...? Please people i've been trying everything I could think of all night long I just want this iPhone to work again,

btw...its been unlocked before (1.1.1) but then got the no WiFi problem so thats why I started all over again.
Thanks!]

Hey I'm stuck at the same scenario. While doing some googling I found out that we need to have the ieraser and bbupdater grant us permission. I'm going to give it a wack, if I find out anything I'll post it asap. If anyone else knows anything else about this please email me at alfredo.mancuso@yahoo.com! I'd gladly donate some cash to whoever has a solution!
 
Dec 17, 2007
26
0
0
#12
hey alflairdo, I am just wondering if you are refering to allowing them to run at the start up?
So I load the files all into my phone along with the proper 04.02.13_G secpack,

Then cd /usr/bin
-launchctl unload -w /System/LIbrary/LaunchDaemons/com.apple.CommCenter.plist
-then i "grant them the permission right?"" which is//
chmod +x ieraser
chmod +x bbupdater

and Then I run ieraser, and it goes through its thing and appears to be working, scrolling through all the numbers of the secpack, and then "erasing the secpack" and gives me the , waiting for next step, the main seems to be erased speech..

then I run the bbupdater -v (version check)

it's supposed to come up with an error telling me pinging of baseband error or something, but instead it gives me all the information so I guess ieraser just isn't doing its job...?!

I've tried all three secpacks, Many many attempts, tried every suggestion, now what lol

again its for the-
04.02.13_G (updated to it accidentely)
3.9 Bootloader which is good.
And I put it on a jailbroken, "activated" 1.0.2 Firmware, with no SIM in during process.
No Wifi, 0049 IMEI, and zippo on erasing the baseband :S

Like Alflairdo said, Please help people, im sure we're not the only two with this weird problem, that evrybody else claims to have gotten past easily.

Cheers,
Andrew
 

wotaru

New Member
May 22, 2008
2
0
0
#13
Hi,i have a firmware 1.1.4 and have it unlocked,cracked the screen and Apple wont replace it unless i get the phone back to factory setting,have done all the resets but installer application won't delete from my screen,then I have it the emergency call screen.....what do i do pleaseeeeeeee