Updated to iOS 8.3 and Safari crashes when uploading photo

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Ltzguy

Zealot
Gold
Jun 22, 2010
1,331
96
48
Right here
#1
I got a notice this morning about the 8.3 update. After reading about it, there was several problems I have been having so I figured it was a good idea to update. Now I have a major issue. When I try to upload a picture to a forum, Safari crashes and the phone returns to the home screen. I tried the same thing on google chrome browser and opera mini. Same result. Thought may be the forum, so I tired a different forum, same thing. I hard reset the phone three times in a row. No luck. I cut it off and back on. Killed my apps. Nothing. Same thing. Evidently there's an issue in 8.3. Anyone having the same issue? Resolved it yet?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#2
I got a notice this morning about the 8.3 update. After reading about it, there was several problems I have been having so I figured it was a good idea to update. Now I have a major issue. When I try to upload a picture to a forum, Safari crashes and the phone returns to the home screen. I tried the same thing on google chrome browser and opera mini. Same result. Thought may be the forum, so I tired a different forum, same thing. I hard reset the phone three times in a row. No luck. I cut it off and back on. Killed my apps. Nothing. Same thing. Evidently there's an issue in 8.3. Anyone having the same issue? Resolved it yet?
Did you do an OTA update? They tend to be more problematic, so I always avoid them. I would restore to the full version on 8.3 in iTunes on your computer. You can use your backup. If that doesn't solve it, restore to factory settings. Before doing any of this, you could try resetting all of your settings in the Settings app as it occasionally fixes this type of problem and is less drastic than a restore.
 

Ltzguy

Zealot
Gold
Jun 22, 2010
1,331
96
48
Right here
#3
Thanks for the reply. Yes I did an ota update. Hate having iTunes on my computer, slows it down. I tried the reset with no luck. Guess I'll try a restore. Ugh. Lol
 
Aug 1, 2007
1,232
44
48
#4
Since this is already a thread.. are there more issues with this like people saying there is? Like battery issues, etc? Just got a new phone so figure I should either stay at 8.2 or update now while it's still empty :p
 

Ltzguy

Zealot
Gold
Jun 22, 2010
1,331
96
48
Right here
#7
I still haven't figured this out. I've got a 64gb and I really don't want to do a restore. Many other issues make this by far the quirkiest iPhone I've had.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#8
I still haven't figured this out. I've got a 64gb and I really don't want to do a restore. Many other issues make this by far the quirkiest iPhone I've had.
Did you try resetting all settings? If that doesn't work, there's nothing you can do besides restore or wait for 8.3.1. If you wait, be sure to do the full update in iTunes rather than an OTA update.
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,791
979
113
65
Florence, AL
#9
Since this is already a thread.. are there more issues with this like people saying there is? Like battery issues, etc? Just got a new phone so figure I should either stay at 8.2 or update now while it's still empty :p
8.3 is the best I've seen for some time. The only issues I have are with 3rd party keyboards. But's they're better than they were.


Sent from my ancient but trustworthy iPhone 5. ☮