Upgrade 1.0.2 to 2.0.1?

shemna

New Member
Oct 27, 2008
25
0
0
#1
Hey there!

I'm using the 2nd generation iPhone with 1.0.2 firmware.. I'm not all that familiar with the iPhone lingo(jailbreak, ziPhone, ssh!).. i'm a bit confused as to it all..
Is the latest version 2.1 ( as on 26th October, 2008)? Can you please let me know how I can upgrade my phone to the 2.0.2 version?

Thanks!
 

Saverino

Zealot
Gold
Jun 1, 2008
4,480
92
48
Burbank
#3
Wait...how are you using the 2nd gen. iPhone on the 1.0.2 FW?
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,384
1,089
113
DC
#5
are you on att? if so, you don't have to worry about it getting "locked". If not, then you will have to re-"unlock" after you update with apps like winPwn, quickPwn, or Pwnage Tool.

You also want to make sure iTunes itself is up to date before updating your iPhone.
 

shemna

New Member
Oct 27, 2008
25
0
0
#6
See, I wasn't kidding when I said I'm not all that familiar with the iPhone lingo! I thought I was using the 2nd gen.. so 1.0.2 cant be on 2nd gen? then was is it that i'm using? ugh! I feel so pathetic!

Also, when you say iTunes, you're talking on the comp rt? not iTunes in the iPhone? because I don't have it! (1.0.2 doesn't have it)
 

shemna

New Member
Oct 27, 2008
25
0
0
#7
and no, i'm not on att. I'm using the phone in india, on a local network here.
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,384
1,089
113
DC
#8
there are two versions of the iPhone. the v1 (aluminum case), and the 3g (plastic case). It is impossible for the 3g iPhone to have software lower than 2.0, so you must have the v1 iPhone. If you want to update your iPhone to the latest software, you will have to use one of three programs to unlock it again for use on your network in India (winPwn [windows], quickPwn[mac & windows], or Pwnage Tool[mac]). See this thread about how to acquire these programs. Once you have them, follow the directions they give you. If you run into trouble, let us know what the problem is.

It can be a scary process if something goes wrong, but it is usually always fixable.
 

shemna

New Member
Oct 27, 2008
25
0
0
#9
there are two versions of the iPhone. the v1 (aluminum case), and the 3g (plastic case). It is impossible for the 3g iPhone to have software lower than 2.0, so you must have the v1 iPhone. If you want to update your iPhone to the latest software, you will have to use one of three programs to unlock it again for use on your network in India (winPwn [windows], quickPwn[mac & windows], or Pwnage Tool[mac]). See this thread about how to acquire these programs. Once you have them, follow the directions they give you. If you run into trouble, let us know what the problem is.

It can be a scary process if something goes wrong, but it is usually always fixable.
Thanks for the help.. I went through the thread you directed me to. I have a question though: I got my iPhone as a gift, and it was already unlocked. So I wasn't involved in the whole process.. so does that mean my phone is jailbroken? Also, in the thread, it says under the 'How to jailbreak iPhones'--
"Firmware 1.0 - 1.0.2: No longer supported. Please update."

What does that mean?
 

shemna

New Member
Oct 27, 2008
25
0
0
#10
Another thing, I use ibrickr to install apps and stuff, does that mean my phone is jailbroken? If so, y exactly shud I use winPwn? ugh! I'm so confused!

I thought I was supposed to virginize my phone before I started updating.. help!
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,384
1,089
113
DC
#11
Yes, you are jailbroken (which is required for ALL unlocked phones). What you are used to doing to install apps and whatnot does NOT apply to the newer software versions. There are now easier and more efficient ways to do that stuff.

winpwn will basically create a custom, hacked version of the iPhone's software to install onto your iPhone. This came about once software 2.0.0 hit, and will NOT work with 1.x.x (which is what the "Firmware 1.0 - 1.0.2: No longer supported. Please update" means).
 

shemna

New Member
Oct 27, 2008
25
0
0
#12
Ok, I understand what winPwn does now. But what do I hafto do now? I mean, what is the first step towards upgrading?
Since I'm already jailbroken, I guess I don't hafto bother with that... It would be great if you could list the steps out to me. I'm sorry if I'm bothering you so much! I just don't want to take any chances..