Upgraded router - can't get wi-fi

sheelz

Member
Bronze
Jan 13, 2009
58
0
6
#1
I've had my home internet router upgraded today. The original one was WEP. This is WPA. However, although my iPhone detects the router and I type in the key my iPhone won't connect. It was a breeze with the old router.

Can anyone help?:eek:
 

s8n666

Member
Bronze
Oct 3, 2008
66
0
6
#2
Check your router and make sure it is broadcasting b/g/n and not just one of the 3. Then check if mac address filter is enabled. If it is, add your iPhone mac address to the list.
 

sheelz

Member
Bronze
Jan 13, 2009
58
0
6
#3
thanks

Check your router and make sure it is broadcasting b/g/n and not just one of the 3. Then check if mac address filter is enabled. If it is, add your iPhone mac address to the list.
As far as I can see the router's configured as above - however, there doesn't seem to be an option to add my iPhone's mac address (dumb question, BTW - where in settings do I find this? I've only had the iPhone for two and a half weeks)
 

s8n666

Member
Bronze
Oct 3, 2008
66
0
6
#4
iPhone mac address is located at: Settings/general/about/wifi address. On your router, check wireless settings for "mac address filter". If there is nothing to that effect, then that is probably not the problem. Recheck your password and make sure that it is entered correctly (check caps etc). The iPhone keyboard is prone to errors 
 

sheelz

Member
Bronze
Jan 13, 2009
58
0
6
#5
iPhone mac address is located at: Settings/general/about/wifi address. On your router, check wireless settings for "mac address filter". If there is nothing to that effect, then that is probably not the problem. Recheck your password and make sure that it is entered correctly (check caps etc). The iPhone keyboard is prone to errors 
I've sorted it - it was a case of changing the wireless channel - this is something I'd not had to do on the old router - so - my iPhone is talking to my router :laugh2: