USB device not recognised

  1. srujjjn

    srujjjn New Member

    Joined:
    Jul 13, 2008
    Likes Received:
    0
    when ever i connect my phone to my computer it sez "USB device not recognized"...n it does not sync wid iTunes also....what to do now....i want to restore but i have very important pictures in my camera album how to mak a backup of them....pl help urgently n how to restore? n actly the labels below the icons are not appearing since a long time
     
    #1
  2. acosmichippo

    acosmichippo Genius Platinum

    Joined:
    Sep 10, 2007
    Likes Received:
    989
    do you have the latest version of iTunes? How old is your computer? What operating system does it have? have you tried different USB ports and cables?

    also, you won't be able to restore until your computer will recognize your iPhone.
     
    #2
  3. Avatar

    Sponsored Advertisement

  4. srujjjn

    srujjjn New Member

    Joined:
    Jul 13, 2008
    Likes Received:
    0
    bugr no problem with computer....

    are there no xperts in this community to guide me through.....

    no prob wid usb, computer...sum prob wid fone .. amateurs don't reply...
     
    #3
  5. acosmichippo

    acosmichippo Genius Platinum

    Joined:
    Sep 10, 2007
    Likes Received:
    989
    Plenty of experts around, but no clairvoyants. we need more information to help you.
     
    #4
  6. Fruit & Veg

    Fruit & Veg New Member

    Joined:
    Aug 29, 2008
    Likes Received:
    0
    Can't synch iPhone to iTunes in windows xp

    OK, I'm having the exact same problem.

    Running a iPhone 3G (UK on O2, not unlocked) - Windows XP Pro on a PC - iTunes 7.7.1 - iPhone software 2.0 - full battery power

    Tried restarting Apple mobile service and ipod service.
    I can't connect so I can't upgrade the iPhone software to 2.0.2
    USB cable is plugged into the PC not a hub.

    I plug in my iPhone and it either says usb device not recognized or thinks about it for a bit and then says could not connect because of an invalid response.

    It has done this since day one. I have maybe synced twice since I got the phone.

    I've searched and read about uninstalling iTunes and then getting 7.5 - which I'm highly reluctant to do as it's a massive hassle plus is downgrading 2 versions really the best answer?

    Surely there's a better way?
     
    #5
  7. acosmichippo

    acosmichippo Genius Platinum

    Joined:
    Sep 10, 2007
    Likes Received:
    989
    Appstore won't work if you downgrade to 7.5, so i definitely don't recommend that.

    The first thing i would try is hooking it up to a different computer. If it does the same thing, i'd take it to Apple, and let them either replace it, or see if they can restore it for you. If it recognizes fine, then that's a whole other story...
     
    #6
  8. Cusca

    Cusca Member Bronze

    Joined:
    Apr 27, 2008
    Likes Received:
    0
    #7
  9. srose

    srose New Member Bronze

    Joined:
    Jun 10, 2008
    Likes Received:
    0
    Hi
    I had a similar problem in Vista. I extracted the Apple Mobile Device Service from the iTunes installation I downloaded of Apple. I used WinRAR to extract it and then removed the Apple Mobile Device Service and installed it again.
     
    #8
  10. beheit

    beheit Guest

    Practically if you have this kind of problem nothing you can do you need to buy a new IPOHONE because Apple doesn't repair phones instead it throw them which is perfect for the environment (because Apple is red and not green) and it send you a new one for the low low low cost of 250 U$. other wise you need to have an extended warranty plan that cost you 70$ per year.

    is this a company that respect their clients or what ?

    Thank you Apple
     
    #9
  11. eoc123

    eoc123 New Member

    Joined:
    Jan 6, 2010
    Likes Received:
    0
    I had the exact same problem. I solved it by changing the USB cable. I might have been using an old iPod cable when I ran into the problem.
     
    #10
  12. RiffRaffMama

    RiffRaffMama New Member

    Joined:
    Jan 11, 2010
    Likes Received:
    0
    I had this same problem and it was driving me insane. I tried the solution posted by eoc123 and it was solved instantly. Get a new cable. Make sure it's genuine. I was trying to use a cheap cable I'd bought overseas and it was just causing problems. All solved now.
     
    #11
  13. nasir.wadood

    nasir.wadood New Member

    Joined:
    Jan 14, 2010
    Likes Received:
    0
    try plugging the usb in the ports on back side of your pc if it didn't worked in front side ports
     
    #12
Similar Threads
  1. KevinDC5
    Replies:
    5
    Views:
    2,768
  2. karla87
    Replies:
    6
    Views:
    2,167
  3. JackCoke
    Replies:
    6
    Views:
    1,557
  4. Terrypin
    Replies:
    2
    Views:
    780
  5. FuelieNova
    Replies:
    9
    Views:
    2,239
Loading...

Share This Page