Veteran Jailbreaker needs help please

Hondamaker

Genius
Gold
May 14, 2007
9,946
671
113
56
Fairborn, Ohio
#1
I've jailbroken my iPhone a bunch of times, each with no real problem. I recently upgraded to 3.0, didn't care for the bugginess, and downgraded back to 2.2.1. Now, after this last j/b, I have no signal, no carrier, etc. I reset the network settings twice to no avail. I tried restoring to factory settings, but iTunes wont let me. I had to re-jailbreak it just to get it to work at all. Please, anyone with any good suggestions?
 

patrickj

Genius
Gold
Sep 2, 2007
6,221
445
83
Austin, Tx
ipadinsight.com
#2
Hey Honda - sorry to hear you're having so much hassle. I did the downgrade yesterday and have some minor issues, but things are mostly cool for me so far. Definitely no signal issues.

What downgrade method did you use? I used this Gizmodo guide (on a Mac)
 

Hondamaker

Genius
Gold
May 14, 2007
9,946
671
113
56
Fairborn, Ohio
#3
Hey Honda - sorry to hear you're having so much hassle. I did the downgrade yesterday and have some minor issues, but things are mostly cool for me so far. Definitely no signal issues.

What downgrade method did you use? I used this Gizmodo guide (on a Mac)
I used the same method, but since I'm not at all familiar with Terminal on my mac, I used the windows method on my PC. Therein lies my problem. If I had used my mac, I think it would be ok. I'm not really sure, though.
 

kenneth

Zealot
Gold
Aug 19, 2008
1,465
0
36
Texas
#4
hey Honda try and restore your iPhone as a new device through DFU mode.
 

badge

Member
Bronze
Feb 23, 2009
122
0
16
Bristol UK
#6
hey Honda try and restore your iPhone as a new device through DFU mode.

I have done the method through windows and found restoring as new phone rather than backup worked for me. I tried backing up after downgrading and had the no signal issues.. Hope you get it sorted.
 

Gonesouth

New Member
Jan 2, 2009
8
0
1
#7
I did the same yesterday, downloaded OS 3.0 but didn't realise I was supposed to register with Apple first. When I tried to revert I got an Error 1031 and couldn't get shot of it.
Ended up getting it back to 2.2.1 by syncing on an old PC.
 

patrickj

Genius
Gold
Sep 2, 2007
6,221
445
83
Austin, Tx
ipadinsight.com
#8
I used the same method, but since I'm not at all familiar with Terminal on my mac, I used the windows method on my PC. Therein lies my problem. If I had used my mac, I think it would be ok. I'm not really sure, though.
I think, as you're planning, that giving it a go on the Mac may be worthwhile. The Terminal parts are not hard - you can literally copy & paste the commands in when required.

I didn't want to go the Windows route because I only run it in a VM, and that adds a layer of possible mishaps ...
 
Jun 19, 2007
33,478
4,542
113
Upper Marlboro, MD
#9
I've jailbroken my iPhone a bunch of times, each with no real problem. I recently upgraded to 3.0, didn't care for the bugginess, and downgraded back to 2.2.1. Now, after this last j/b, I have no signal, no carrier, etc. I reset the network settings twice to no avail. I tried restoring to factory settings, but iTunes wont let me. I had to re-jailbreak it just to get it to work at all. Please, anyone with any good suggestions?
You didn't actually run QuickPwn, did you?
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,201
144
63
#12
In windows after opening quickpwn and getting the instructions to hold the home and power buttons for 15 seconds then the power button for two seconds...you stop. Open iTunes and it will activate your phone. Only after the phone is activated should you continue with the jailbreak. Took me 3 tries before I realized this. Glad you got it working, just wanted to post this here so anyone else trying might find it useful.