voicemail button not working on 3G...

bunnunce_boy3

New Member
Bronze
Jan 3, 2008
120
0
0
#1
so when i hit the phone icon then the voicemail icon, nothing happens. I haven't been able to set up my voicemail and can not receive voicemails...this sucks..

Also, the 3G's battery life sucks, and there is a short delay when i press any icons...i loved my iPhone and wish i didn't get rid of it to get the 3G...

any advice? I have an appt. with a mac genius today. Hopefully i get a new iPhone 3G
 

galos11

New Member
Jul 6, 2007
1
0
0
#2
The same thing happened to me. I ended up calling myself(dial your phone number) and following the prompts to set up your voicemail. After I did this the voicemail button worked and I set up a password and greeting. Hope this helps.
 

bunnunce_boy3

New Member
Bronze
Jan 3, 2008
120
0
0
#3
thanks i will try that...too bad that wont fix all the other problems!
 

BigCiX

Zealot
Gold
Jul 11, 2008
1,445
5
38
Bakersfield, CA
#4
i thought mine wasn't working also but i figured it out. are you guys tapping the voicemail button then clicking on the person who left the voicemail. if you look down on the bottom of the screen you'll see that the voicemail is actually playing now. just hold the phone up to your ear.
 

bunnunce_boy3

New Member
Bronze
Jan 3, 2008
120
0
0
#5
no its not that...i cant even open the voicevoicemail screen...
 

vip

New Member
Jul 10, 2008
13
0
0
#6
The same thing happened to me. I ended up calling myself(dial your phone number) and following the prompts to set up your voicemail. After I did this the voicemail button worked and I set up a password and greeting. Hope this helps.
This also worked for me too.

Thanks. Not sure why I didn't try that in the beginning.
 

tm1nor

New Member
Jul 1, 2007
12
0
0
#7
so when i hit the phone icon then the voicemail icon, nothing happens. I haven't been able to set up my voicemail and can not receive voicemails...this sucks..

Also, the 3G's battery life sucks, and there is a short delay when i press any icons...i loved my iPhone and wish i didn't get rid of it to get the 3G...

any advice? I have an appt. with a mac genius today. Hopefully i get a new iPhone 3G
dude i had the same problem...

when you call yourself, and it says " person hasn't set up their vm " CLICK *...

boom, set it up, and youre done :)

took me the weekend to figure that junk out
 

kisstine

Zealot
Gold
Jul 12, 2007
1,332
1
38
50
Northern California
#8
dude i had the same problem...

when you call yourself, and it says " person hasn't set up their vm " CLICK *...

boom, set it up, and youre done :)

took me the weekend to figure that junk out
The issue is that we shouldn't have had to figure it out. The AT&T paperwork gives instructions for setting up visual voicemail and they are inaccurate. It doesn't say anything about needing to dial in to set up your old school voicemail.

If you're gonna give me directions, it'd be nice if they were correct. That's all I'm saying.
 

Wiggo

Member
Bronze
Jul 7, 2007
103
0
16
Memphis
#9
Just checked on my upgraded 3G, and sure enough, hitting voicemail icon CALLED my voicemail. Called my 3G (from the 3G), left a message, and now visual voicemail is back.
 

jbarrack

New Member
Bronze
Jul 2, 2007
453
0
0
New York
www.facebook.com
#10
I had the same issue. I called my phone and when it came to voice mail I hit star. Then went through a set up process and I was all set. A few seconds later (30 Seconds about) my voicemail button worked.