Weird Contacts Problem

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Hondamaker

Genius
Gold
May 14, 2007
9,918
662
113
55
Fairborn, Ohio
#1
I'm not sure if this is an iPhone 4 issue or an iOS 5 issue (I have the GM), but in my contacts list I have, naturally, my wife's contact info. Its never changed. But lately, when she calls, her name doesn't appear any more, just her number. When I call her, her name appears appears as usual, and in the Recent Calls list, her name will appear when I've called her. When she calls me, however, only her number appears in the Recent Calls list. Also, under her name it says 'mobile' when I call her, but the incoming call shows 'main'. I only have her contact number under the 'mobile' category. Anyone else experience this?
 

Hondamaker

Genius
Gold
May 14, 2007
9,918
662
113
55
Fairborn, Ohio
#2
OK, I was never able to fix this issue, so I tried this: I deleted my wife from my contacts, then re-entered her name and contact info. I'm still getting the same problem. She is the only contact who's info comes up as just the phone number. I have her number formatted just like all the others [ (000)000-0000]. Anyone have a clue? I know out of the thousands of members here, at least one other person had to have had this issue.
 

Edge1978

Member
Bronze
Feb 7, 2009
245
5
18
#3
My Aunt is having the same issue since updating her iPhone 4 to iOS 5. When her daughter calls her, her name appears as normal. However when her daughter texts her, just her number appears. Cannot figure it out either
 

Test-Pilot

Member
Bronze
Jan 20, 2008
118
9
18
#4
My wife's phone has it too. When I text her, on the text that she receives, my number shows in the ID field, and not my name.
 

billnye97

Contributor
Silver
Jun 21, 2007
848
75
28
Cleveland
#6
OK, I was never able to fix this issue, so I tried this: I deleted my wife from my contacts, then re-entered her name and contact info. I'm still getting the same problem. She is the only contact who's info comes up as just the phone number. I have her number formatted just like all the others [ (000)000-0000]. Anyone have a clue? I know out of the thousands of members here, at least one other person had to have had this issue.
Same thing with me. I have one contact that doesn't show the name when he calls but is fine when I contact him. For what it's worth I imported my contacts through Google by setting up an Exchange account.