Weird pop email problem - comcast with outlook

Discussion in 'iOS Software' started by JimD, Dec 24, 2007.

  1. JimD

    JimD Member

    I have had comcast email for quite some time, and use Outlook on my PC to access both of my addresses at comcast. I setup my new iPhone to access these same 2 accounts, using the same username and password that has been used by my PC for many months.

    Right after doing so I noticed that after the iPhone tries to fetch email it cuases my PC email to act weird. When the PC tries to get messages, it pops up a requester for the password of my email accounts. The requester is titled "Enter Network Password". The server, username and password are all already filled in, but the "save this password in your password list" is unchecked. This requester sits there waiting for me to click the "ok" button.

    Has anyone else seen this sort of behavior, and do you know what causes it or how to eliminate it? I check the "save this password" box and hit OK and all seems well until the next time the iPhone tries to get mail from my comcast accounts.


    Is it possible that two clients cannot share access to comcast email?
  2. meiphones_brill

    meiphones_brill New Member

    Yes - pop3 can't cope with simultaneous access of the same mailbox. You can actually screw the mailbox up completely if you're unlucky. There's no work-around unfortunately. An ISP can tinker with the pop locking but you're unlikely to have any joy with a large ISP.

    IMAP is a better solution if you can use it.
  3. Avatar

    Sponsored Advertisement

  4. KGMJr32

    KGMJr32 New Member

    I have issues sending but not receiving form Comcast account. I also am the only one accessing the account. Do a search on the internet...There may be something out there on it. Have you tried the Comcast website?
  5. JimD

    JimD Member

    Yes, I tried the comcast website. It showed how to setup the iPhone for access to my account, and the server address for outgoing mail was different from what was in the phone the first time I tried to access it. I changed this and the result was the same. My PC still sits there stupidly asking for the password it already has, until I click cancel - and then it goes and gets my email.

    This sounds a bit like a problem discussed all over the web about Outlook 2002 and a corrupted password entry in the registry, but I don't understand how this would suddenly have developed after configuring an iPhone to access the same account. No changes were made to the PC.
  6. JimD

    JimD Member

    This is my personal email - not my corporate email. There is no Exchange server involved, thus IMAP is not an option.

    This is a POP email server (mail.comcast.net), and from what I've read there should be no issue with more than one client accessing the messages - so long as they don't delete the messages from the server after fetching them. I don't know about simultaneous access or any potential issue there, but the testing I was doing last night was sequential, possibly a minute or more apart.
  7. JimD

    JimD Member

    I examined an error message this morning from Outlook, and it said "Locked by another POP3 process". This lends credence to what you are saying, but I deleted the accounts from my iPhone last night - so why would there be a conflict this morning?
  8. meiphones_brill

    meiphones_brill New Member

    Trust me - pop3 won't allow more than one concurrent connection without problems. It depends on the pop3 server, but what happens is the server will have a stale pop3 lock file that has to be flushed. Most pop3 servers set up a cron that runs every so often to clear these lock files out.

    If you stop collecting mail on that account from ALL your computers for something between 25 minutes and 4 hours (depending on the isp's setting) then the cronjob will remove that lock file and you'll be running again.
  9. JimD

    JimD Member

    Only once have I seen the error that said that another POP3 process had locked things. Much more often what I see is what I described earlier - my PC keeps popping up this "Network password" request, and there are no errors to examine. The strange thing is that if I go to email accounts on this PC and press the "test settings" button it logs on to the server and everything is fine again - until the next time this box pops up.
  10. meiphones_brill

    meiphones_brill New Member

    That sounds about right. It is all down to the two machines overlapping. I have one customer who manages it reasonably well with one of his offices collecting mail on the hour and at the bottom of the hour, and the other collecting at a quarter past and a quarter to.
  11. JimD

    JimD Member

    OK Here's an update. I deleted the "protected storage system provider" key from the registry of my PC, and re-entered the passwords for my email accounts into Outlook. This seems to have stemmed the tide of "Network Password" requests whenever Outlook accesses my Comcast email accounts.

    I then created a new Comcast ID expressly for my iPhone, and only the iPhone accesses that mailbox; the PC never does so. I then configured my other two mailboxes to forward all messages to this third one. My iPhone is configured to fetch the contents from this mailbox every 15 minutes (best it can do with POP3 apparently).

    I configured my wife's accounts the same way. I sent test messages to both her and my primary comcast accounts. Both our PCs and iPhones received the messages. Rube Goldberg would be proud.

    I will use things this way for a while before I begin to experiment further.

    I added thanks to you (me) :) for your help with this.
  12. mantiss

    mantiss New Member


    I have a similar problem with comcast email. If I just recently checked my mail on my iphone and I try to use Outlook Express to check comcast email I get the Password screen pop up. I have the correct password entered but it won't let me send or receive email. I usually wait a few minutes and it works.

    Let me ask you.... Do you get the "This message has not been downloaded from server" message a lot on your iphone when downloading Comcast email? I do alot. I eventually had to open a GMAIL account and use it as IMAP and have my comcast email forwarded to the Gmail account. The IMAP Gmail account works 99% of the time on my Iphone. The Comcast POP3 works less than 50%. Very frustrating and Apple Nor Comcast wants to take responsibility for the issues with POP3.
  13. JimD

    JimD Member

    I do indeed. I thought it was only when I am in an "edge" environment, but I have not yet confirmed this.

    I installed an access point at my office, and of course I have one here at home - so for the most part I don't use Edge for email transfer.
  14. mantiss

    mantiss New Member


    I use wireless at my home also and I still get that message. Like I said, I found that if I had my email forwarded to a Gmail IMAP account it would open just fine.
    I had not used Gmail before this but now that I tried it I like it. All my comcast email gets forwarded there now.
    If you try the Gmail workaround remember to set it up as IMAP and not the default POP3 setting. ALSO you can not use the automatic setup function in the Iphone for GMAIL. That only sets up to Gmail POP3. Use the OTHER button and enter your info manually. Its not too much harder.

    I am very frustrated with the lack of help from Apple and Comcast on this matter.

    I have also had my Comcast email account frozen by the problem of both apps trying to access it at the same time. I had to have Comcast support reset my email account on their servers because it got corrupted.

    Good Luck...!!!!
  15. dsulvett

    dsulvett New Member

    never had a problem with my blackberry! no excuse apple
  16. dsulvett

    dsulvett New Member

    your correct there SHOULD BE NO issues, but there is.... I hope apple fixes it
  17. ffitz2

    ffitz2 New Member

    There is an iPhone defect that causes the problem. The iPhone POP3 implementation fails to log out of the POP3 transaction, locking up the mailbox. Other POP3 clients are unable to log in. I can't understand why Apple hasn't fixed their defective implentation of the POP3 protocol.

Share This Page