When connected to the computer my iPhone disconnects then connects.... so on

Aug 26, 2007
4
0
0
#1
I just moved my computer upstairs and everything was working fine but now when i plug in my iPhone to my computer through the dock or even just straight with the usb cord the iPhone randonmly sometimes disconnects then connects. I tried to turn it off then on again, but still to no avail. everything was working fine and everything is hooked in correctly?

i don't want to restore because i'd lose all my mods. help?
 

scrowner

New Member
Bronze
Jul 4, 2007
120
0
0
#2
I would disable WiFi and BlueTooth just to see if it helps. Re-check/replace your cable from the iPhone to the computer.
 

The Apple

Zealot
Gold
Aug 2, 2007
3,105
0
38
Indiana
#3
I also have this problem that I cannot seem to resolve. I tried the mentioned ideas, which did not work. I will have to keep my eye on this thread to see if someone can figure this out.
 
Dec 11, 2008
1
0
0
#4
My problem is similar but slightly different. It doesn't randomly disconnect, it always and only disconnects whenever it starts to backup my phone. When syncing or restoring it says "iTunes could not back up the iPhone "iPhone" because the iPhone disconnected."

I can't even restore my iPhone because it automatically starts to backs it up, meaning it disconnects so it cancels. I had to reset my iPhone (the reason being so i could unlock the sim card) manually through the phone settings because i couldn't restore it via iTunes.

The weird thing is, it doesn't seem like it disconnects. As in, the tone it plays when it connects to the computer doesn't play when it supposedly "disconnects and reconnects".
 

styfle

Zealot
Gold
Mar 31, 2008
3,381
7
38
#5
I have this problem now! :(
I have it plugged in and it seems to be working fine when all of a sudden it unmounts and I hear the "do-do" noise and it reconnects a couple seconds later. I thought it was a faulty USB cable but I tried another one and it does the exact same thing: it disconnects almost every minute so I can't even sync :(

Anyone have a fix?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#6
Did you try an different USB port?
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#7
I have this problem all the time and it's definitely a low USB power issue with me.

Try a different USB port on your computer (I have one particularly sweet one on mine that usually works). Also try disconnecting other USB devices, especially ones that draw power from the USB.

I've been meaning to look into a PSU swap that might give me more power on the USB rail. I haven't yet.
 

BrownGem

Zealot
Gold
Feb 27, 2009
1,623
23
38
Texas
#8
Are you all using Macs? Maybe a recent update caused an issue? Seems strange so many people are having the same issue out of the blue.
 

styfle

Zealot
Gold
Mar 31, 2008
3,381
7
38
#11
I'm on mac and its odd that there is an issue at all because 1) I have a year old macbook that definitely has USB 2.0 ports and 2) there are only 2 ports on here so how could it be a power issue?
I'll try unplugging my mouse (lol) to see if that helps.
 

vishal1

New Member
Feb 22, 2010
3
0
0
#12
Dear friend,
i also suffered with this kind of problem but some option to resolve this problem. when i was connected and start sync my ringtone than it suddenly stop and one error message came, after this suddenly itune is closed.
1) check for virus in PC, some virus can affect to the iTunes
2) PC configuration is also have solution.
3) downlode iTunes again.
 
Last edited by a moderator: