When iPhone Auto lock's loses WiFi connection?

Mar 31, 2009
5
0
0
#1
Is this normal?

Whenever my iPhone goes into autolock mode or if I manually lock it, my iPhone loses connection with wifi..

Is there any kind of app that will keep it active while locked?

I like to access my iPhone remotely but it keeps losing connection every time it auto-locks or if I press the lock button on the iPhone...

Thanks!
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#2
This is normal. Some apps can defeat this when they are left running, but there is nothing you can otherwise do to prevent it from happening unless you're jailbroken.
 
Mar 31, 2009
5
0
0
#3
This is normal. Some apps can defeat this when they are left running, but there is nothing you can otherwise do to prevent it from happening unless you're jailbroken.
I am jailbroken!

Could you possibly suggest some apps? I haven't really been able to find any in cydia.

Thanks again!
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
40
Philly
#4
Two jailbreak apps that did it in the past were "keepalive" and "insomnia"... I'm not sure if any of these have been ported to 3.0, though.
 
Jan 29, 2013
6
0
1
#6
I have 2 iPhones in the house and only the 5 loses wifi connection when locked? Any ideas why this happens ?


Sent using iCafe app
 

Rugaby

Genius
Gold
Feb 18, 2011
7,122
1,220
113
Washington state
#7
I have 2 iPhones in the house and only the 5 loses wifi connection when locked? Any ideas why this happens ?


Sent using iCafe app
Some apps on certain platforms and operating systems take a little to drop the connection or need for the connection when the phone sleeps or is locked. The other iPhone drops it eventually correct?
 
Jan 29, 2013
6
0
1
#8
No. Every time I unlock the 4 its connected to wifi but the 5 is not I believe this started after a Rogers tech told me to reset my network setting on the phone through the settings cause I couldn't text while in a store which when on Telus was never a problem


Sent using iCafe app
 

Booyow1204

Contributor
Silver
Jul 14, 2010
595
40
28
Las Vegas
#9
It seems my 5 did this before I upgraded to 6.1, I always thought it was a battery saver to disconnect wifi once the phone was locked. Now I noticed it doesn't do that anymore since I updated the software. My old 3GS would always let go of wifi as well once the screen is locked...Wonder if the internet provider/router makes a difference
 
Jan 29, 2013
6
0
1
#10
I also have updated the day before this started


Sent using iCafe app
 
Jan 29, 2013
6
0
1
#11
I did find a solution actually on Google. I went into settings and instead of choosing my home wifi I clicked other and entered the domain name and password and that seems to have helped. Hope it keeps working


Sent using iCafe app
 

Hallea

New Member
Jan 30, 2013
7
1
3
CA
#12
Hi! I am also experiencing the same situation similar to the OP, and as I read this thread, I learn why things such this is occurring. I am a new member and thanks for this opportunity to read some solutions for free.
 
Jan 29, 2013
6
0
1
#13
So far my solution for wifi disconnecting is still working woohoo


Sent using iCafe app