Why do I constantly get the following error after installing V7.7?

Sep 18, 2007
27
0
1
Los Angeles, Ca
#1
Ever since Apple updated iTunes to v 7.7 I get the following error when connecting my iPhone 3G:

"iTunes was unable to load provider data from sync services. Reconnect or try again later"

This has been further compounded along with the following error since they updated to v7.7.1:

"iTunes cannot sync information with iPhone "XXXX" syncing has been disabled on this computer. Do you want to enable syncing on this computer?

If I go through this process about 10 times (enabling syncing and clicking ok with the top error message) it will eventually work as normal until the next re-boot.

This is running on an XP laptop w/SP3 and Outlook 2003. I'm also syncing email, calendar and contacts with an exchange server and not locally on this machine.

It's driving me nuts!

TIA
 

kokogirl

New Member
Gold
Sep 8, 2007
2,319
1
0
47
Sunny Florida
#2
Last time I had an iTunes error, I had to uninstall and reinstall iTunes. Maybe it got messed up when you updated.

I was on a Mac, but I think the same things happen on the PC.
 

dturner

Zealot
Gold
Dec 15, 2007
5,725
12
38
Louisville, Ky.
#3
I would uninstall iTunes,reboot computer, and reinstall iTunes again. You won't lose any music or other files and this seems to solve the problem 90% of the time.
 
Sep 18, 2007
27
0
1
Los Angeles, Ca
#4
Yeah been there done that several times. Even disabled the firewall and antivirus software just in case. I went ahead and rolled back to the original release (v7.7.0) so that I don't get both pop up errors. Now I'm back to just the "load provider data from sync services" error.