Why doesn't iMessage work on 3G anymore?

Discussion in 'iPhone 4S' started by Luis.g.95, Mar 12, 2012.

  1. Luis.g.95

    Luis.g.95 New Member

    Joined:
    Feb 3, 2012
    Likes Received:
    0
    Ever since a couple of days ago, I can't use iMessage on 3G. It just sends messages as texts. It works perfectly fine on wifi.I have an iPhone 4S running on the latest update if that helps. Is anyone else experiencing this problem? Or know how to fix it?
     
  2. OhMatty

    OhMatty New Member

    Joined:
    Feb 22, 2012
    Likes Received:
    0
    I have a 4s (CDMA) running on 5.0.1 firmware. I just tested iMessage on 3g and it seems to be working fine for me.

    Here is a little something I came up with in a quick Google Search. -->


    "Enorym writes...
    don't worry.. I just found out you can only use iMessage over WiFi.. which I think is total BS..
    Not true at all i have been using imessage since ios 5 beta 1 and it works over 3G
    It would only work over wifi on the ipod touch and non 3g ipads as thats the only source for data..
    Also if there is no data connection it will default to sending an sms"

    The site that came from can be found... HERE!

    EDIT-- Also, it may not be your phone that isn't working with iMessage. The recipient on the other end of the text may not have their iMessage on. I've had that issue with iMessage texting (well iMessaging >.<) my girlfriend. She never has her's turned on so all my messages are sent as texts.
     
  3. JDem

    JDem Contributor
    Bronze

    Joined:
    Jan 19, 2011
    Likes Received:
    27
    Actually may have been a spotty, minor iMessage "outage" over the last couple of days. I've had a few people (all iPhone users who I normally can iMessage with) tell me they've texted me and either got no response (because I did not receive the message) or that I was green (regular SMS) when they sent a message.

    Oddly, the only people I've been having iMessage issues with are other VZW customers. Seems to be working as normal today.
     
  4. Luis.g.95

    Luis.g.95 New Member

    Joined:
    Feb 3, 2012
    Likes Received:
    0
    Thanks for the input :) I found out how to do it, all I did was reset my network settings and write the information back on :)
     
  5. itsalexaye

    itsalexaye Member
    Bronze

    Joined:
    Aug 6, 2011
    Likes Received:
    2
    Glad you found out how to fix it :)
     

Share This Page