Why is my phone backing up so incredibly slow?

Jul 26, 2007
24
0
0
#1
The last couple times ive added music (I just unhooked it because i couldnt wait any longer) to my phone and now that im downloading the 2.2 upgrade it backs my phone up ridiculously slow! It's been 30 minutes and its barely 1/4 of the way down! WTF?
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
31
Atlanta, Georgia
#2
The backup process time from Firmware 1.xx to 2.xx has been substantial. Some members have mentioned 8 hour backups or longer.

There is a way to make the backup faster and it has worked for quite a few people.

Plug your iPhone in and under the devices tab in iTunes, click on it. Uncheck the "Automatically Sync iPhone". Then unplug and replug the iPhone into your computer. Now when you plug it back in, right click on the iPhone under Devices and a drop-down menu should appear, select "Reset Warnings" and push Sync.

This is the critical point. You will now see a popup asking if you would like to allow iTunes to send information to Apple, select DO NOT ALLOW.

That should take care of your backup woes.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#3
If it's doing a long backup every time you connect the phone, something's not right. It will take a long time to do a full backup, but subsequent syncs should be incremental backups and go much faster (minute or two as opposed to an hour or more).

I would go into iTunes settings and delete any backups you have of your iPhone and let it sync and make a fresh full backup. See if that speeds it up for subsequent syncs.
 

dturner

Zealot
Gold
Dec 15, 2007
5,725
12
38
Louisville, Ky.
#4
I would go into iTunes settings and delete any backups you have of your iPhone and let it sync and make a fresh full backup. See if that speeds it up for subsequent syncs.
You very well may have a corrupt backup which could cause this so I would follow this advice. As was stated, the first one could take some time but after that just a couple of minutes.
 

aenti

Zealot
Gold
Jul 8, 2008
1,155
0
36
Maryland
#5
I happen to have the same problem, it sucks. Especially when all you want to do is just add a new album.
 

dturner

Zealot
Gold
Dec 15, 2007
5,725
12
38
Louisville, Ky.
#6
I happen to have the same problem, it sucks. Especially when all you want to do is just add a new album.
If you want to do something like this and not necessarily do a backup, hit the X and it will skip the backup. Just make sure you do it before the backup starts. If it has started and you hit the X,IMO you are asking for trouble. This is one cause of corrupt backup files.
 

aenti

Zealot
Gold
Jul 8, 2008
1,155
0
36
Maryland
#7
Just out of curiosity, do you guys have your information sent to Apple every time you sync? Or no?
 

dturner

Zealot
Gold
Dec 15, 2007
5,725
12
38
Louisville, Ky.
#8
Just out of curiosity, do you guys have your information sent to Apple every time you sync? Or no?
I really don't know to be honest. Don't know if I said OK to that or not, but my backups rarely take more than 2-3 minutes. Closer to 2. Once in a great while it will take 15-20 min. Not sure why though.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#9
I'm pretty sure I clicked no (my usual practice), but I'm not positive to be honest. I don't have any problems with the length of my backups either.
 
Jul 26, 2007
24
0
0
#10
I did the do not send to Apple thing but I cant find where you delete the backups in the settings. It's still going slow as f*ck:(