Wi-Fi issues on eBay bought iPhone 3G

egwinz

New Member
Feb 14, 2009
4
0
0
#1
Hi all,

I just bought an unlocked, jailbroken 3G on ebay (firmware 2.2). I'm having major trouble with wi-fi. Because the problem seems to be common from reading around, I'm not sure this is really due to a defective device. That said, the common solutions haven't helped me.

The issue is this: the iPhone will connect to a wi-fi network, and get full signal. Most of the time it will initially connect fine, and load pages, albeit a bit slowly. After anywhere between 30 secs to 5 minutes, it will start failing to load pages, while still getting full signal. Other applications (like iTunes store or weather) have the same connection issues. In Safari I get 'Can't connect to network' when it times out.

Sometimes turning off wi-fi or rebooting the phone lets it start loading pages again, but the fix is never permanent, when it even works at all.

I also have an iPod touch 2nd gen, which has none of these problems: in fact, I've made sure that all setting are identical on both devices (save of course for the devide's own ip): router address, DNS, etc. Works flawlessly with ipod and only temporarily with iPhone.

I read around that a lot of people got similar issues solved by using openDNS servers: I tried that, and while it seems to slightly increase the time it takes for the connection to become useless, it hasn't fixed the problem.

I'm on a university network, and don't use a router to access the it, so doing any sort of reset on that side is impossible. Same for MAC address filtering: that can't be turned off for troubleshooting. Note, however, that my device is fully registered on the network, and we were able to determine it gets a valid ip when connecting.
(Other iPhone users on campus have no such problem, and the IT guy is really stumped by my case).

Using public wi-fi yields better performance (speed and connection time), but it also eventually dies out, especially if I lock the screen.

Any thoughts of what else I might try? I hope I didn't just buy a lemon...
Thanks!
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,384
1,089
113
DC
#2
the fact that it happens on all networks is a bit troubling. i know you said you checked the settings with your ipod, but i would still try to reset all settings, and see what happens.

If that fails, i think the only other option is to restore it. have you done that since you got it? If not, i would recommend doing it anyway. Who knows what state it is in...
 

egwinz

New Member
Feb 14, 2009
4
0
0
#3
Thanks for your reply!

No, I haven't done a factory restore since I got it. I was under the impression that that would re-lock the phone. Isn't that right? Since it seems to be my only option, I may have to do that anyway. Now, restoring will not cause the phone to update to 2.2.1, but just revert to the firmware version the phone came with, right? I hear the latest one isn't ready for jailbreak yet.
 

egwinz

New Member
Feb 14, 2009
4
0
0
#5
Ok, just an update on the situation:

I did a restore to 2.2: everything went smoothly, unlocking and all.
This hasn't solved the problem, though. I still get the same issues
with wi-fi.

Anyone has thoughts on what my options are at this point?
 

acosmichippo

Genius
Platinum
Sep 10, 2007
15,384
1,089
113
DC
#6
sounds like a bad wifi card... has it been like that since you got it? I think your best recourse is to get a refund from the seller.

if it's a 3G, it's still under warranty, but i think that only holds if you have a valid ATT contract. You COULD try taking it to Apple if all else fails.
 

egwinz

New Member
Feb 14, 2009
4
0
0
#7
Yeah, it's been like that since I got it.
Ok, I'll try and take it up with the seller.
I doubt either ATT or Apple would help me with this one...