Wi-Fi not working with Belkin router

Discussion in 'iPhone' started by gcvt, Jul 4, 2007.

  1. gcvt

    gcvt Zealot

    When I'm at home using my Airport Express, my wifi works flawlessly.

    However, when I'm at my girlfriend's house, it doesn't work at all. She's using a Belkin router and it works fine with her MacBook and my MacBook Pro.

    My iPhone says it's connected to her network, gives a full signal on the wifi icon, etc. but when I try to load a webpage, it tries and tries and then says "Safari can't open the page because it can't find the server.".

    Very frustrated! Any ideas?

    I can post the details from the wifi menu in Settings if needed.
  2. Matt

    Matt Member

    I have the same problem! What's the deal anyone know?
  3. Avatar

    Sponsored Advertisement

  4. eplantz

    eplantz Member

    if you have to set up a password to use the router, be sure to turn OFF the IPHONE option to AUTO-CAPITALIZE
  5. Fred87nc

    Fred87nc New Member

    theres a wifi connection aroun my gf house and same thing gets full signal but edge is still active I guess apple doesn't like belkin anyone find a solution also what cheap router do u recommend cause I need one for my house for my clearwire (clearwire sucks btw)
  6. gcvt

    gcvt Zealot

  7. charlich

    charlich New Member

    Wifi solutions

    I had similar problems but spend 3 hours of quality time with Apple tech support last Sunday solving my problem. First, reset your router by unplugging it for several minutes. Then reboot your router. Reset your network settings on the iphone. You probably need to reset your iphone wifi setting to Wep +Hex not Wep. Then you should be prompted for any encryption number if you have it. It's as simple as that but I had the good folks at Apple scratching their heads. You may need to repeat this process if you move from one hotspot or wireless setting to another. Oh well....

    Despite the length of time , the Apple people were great! Best.
  8. sparkle

    sparkle New Member

    tried firmware update?

    I had similar issues with a dlink router but I just upgraded the firmware and it worked like a charm. My wireless router was about 2.5 years old. It's worth looking for new firmware if you're having problems.
  9. ksk

    ksk New Member

    wifi not working on belkin router

    hi his page is not there any more , I am facing the same issue connecting iphone to wifi on belkin router


  10. jaybird360

    jaybird360 New Member

    Got it!

    My boyfriend figured it out...just need to Login to Belkin web site and allow the Iphone to access...I guess I had some security set up that wouldn't allow the Iphone to access the router. Now all is well. I can get more detailed instruction if anyone needs it. I'm not too techy but I'm sure my boyf can type out the details if I ask, post here if you want them.
    :laugh2:
  11. joaoeduardo87

    joaoeduardo87 New Member

    Could u please tell me how u fixed this problem thanks.


  12. encee

    encee New Member

    Once you have the phrase that codes the router, how do you translate this to the iPhone? There are so many options in setup. Is the router pharse the password? etc
  13. wingate

    wingate Member

    Try calling Apple support: if you just purchased your iphone they should be able to talk you through it: 1-800-275-2273
    Your iphone should pick up the ip adress of the wireless router. If your router has a password or encryption, the iphone will ask you automatically for the password.
  14. worldcitizen

    worldcitizen New Member

    I just bought a Belkin N Wireless Router today and set it up for my 2 PC's & when I went to get my iPhone it had already registered the Belkin wi-fi and I could use wifi instantly without any configuration or problems. I went into airplane mode just to make sure and I could access safari, email, iTunes and download apps at very good speeds. At last now I have wifi!! The Belkin router just worked out of the box for me. Of course I knew to go into my modem's browser address and turn on NAT. Everything just worked and I never even used the cd software included to set it up. No passwords or errors or problems. Terrific!!
  15. germandiazm

    germandiazm New Member

    This might be helpful

    If this helps anyone… I had the problem that my iPhone didn’t detect my wi-fi router at home, and after I entered my router (192.168.2.1) I started playing around changing settings made 2 changes:
    -Changed the 802.11e QoS configuration (whatever that means) from off to on.
    -Replaced an hyphened character (á) in the SSID for a normal character (a).
    After doing this 2 steps clicked on aplly, waited 25 seconds for it to restart and now my iPhone detect my home wifi conection.
    I don’t know which one of this steps is the one, but is 2 in the morning and I’m not gonna look into it now.
    Hope this helps anyone.
    G.

Share This Page