Wi-Fi not working

Discussion in 'iPhone' started by gcvt, Jul 4, 2007.

  1. gcvt

    gcvt Zealot
    Gold

    Jun 21, 2007
    1
    When I'm at home using my Airport Express, my wifi works flawlessly.

    However, when I'm at my girlfriend's house, it doesn't work at all. She's using a Belkin router and it works fine with her MacBook and my MacBook Pro.

    My iPhone says it's connected to her network, gives a full signal on the wifi icon, etc. but when I try to load a webpage, it tries and tries and then says "Safari can't open the page because it can't find the server.".

    Very frustrated! Any ideas?

    I can post the details from the wifi menu in Settings if needed.
     
  2. Matt

    Matt Member
    Bronze

    May 10, 2007
    0
    I have the same problem! What's the deal anyone know?
     
  3. Sponsored Advertisement

  4. eplantz

    eplantz Member
    Bronze

    Jul 1, 2007
    0
    if you have to set up a password to use the router, be sure to turn OFF the iPhone option to AUTO-CAPITALIZE
     
  5. Fred87nc

    Fred87nc New Member
    Bronze

    Jun 19, 2007
    0
    theres a wifi connection aroun my gf house and same thing gets full signal but edge is still active i guess Apple doesn't like belkin anyone find a solution also what cheap router do u recommend cause i need one for my house for my clearwire (clearwire sucks btw)
     
  6. gcvt

    gcvt Zealot
    Gold

    Jun 21, 2007
    1
  7. charlich

    charlich New Member

    Jun 18, 2007
    0
    Wifi solutions

    I had similar problems but spend 3 hours of quality time with Apple tech support last Sunday solving my problem. First, reset your router by unplugging it for several minutes. Then reboot your router. Reset your network settings on the iPhone. You probably need to reset your iPhone wifi setting to Wep +Hex not Wep. Then you should be prompted for any encryption number if you have it. It's as simple as that but I had the good folks at Apple scratching their heads. You may need to repeat this process if you move from one hotspot or wireless setting to another. Oh well....

    Despite the length of time , the Apple people were great! Best.
     
  8. sparkle

    sparkle New Member

    Jul 5, 2007
    0
    tried firmware update?

    I had similar issues with a dlink router but I just upgraded the firmware and it worked like a charm. My wireless router was about 2.5 years old. It's worth looking for new firmware if you're having problems.
     
  9. rollinfromhell

    Gold

    Aug 1, 2007
    38
    Ok, when I use my neighbors across the street its fine! but when I try to use my own network, i have a D-Link DI-514, and itll work on the first few websites, then go extremely slow to almost nothing, and i can be at low recepetion and itll be just as fast in the first few websites.. anything I can do? I've reset the router, changed it to WEP and still wouldn't work...and yes wireless on the laptops work good, but the iPhone..
     
  10. Crash Override

    Bronze

    Aug 9, 2007
    2
    Have you updated your firmware?

    I had issues with all my gaming devices connecting to my home wifi. (XBox 360, PS3, Wii) until I updated the firmware on the wireless router. The 360 was slow and the other two wouldn't connect at all until I did the firmware update. Now they all connect easily and run fast. This was before i got my iPhone, but I've had no issues getting wifi at home with my iPhone.:)
     
  11. ksk

    ksk New Member

    Sep 25, 2007
    0
    wifi not working on belkin router

    hi his page is not there any more , i am facing the same issue connecting iPhone to wifi on belkin router


     
  12. jaybird360

    jaybird360 New Member

    Aug 23, 2007
    0
    Got it!

    My boyfriend figured it out...just need to Login to Belkin web site and allow the iPhone to access...I guess I had some security set up that wouldn't allow the iPhone to access the router. Now all is well. I can get more detailed instruction if anyone needs it. I'm not too techy but I'm sure my boyf can type out the details if I ask, post here if you want them.
    :laugh2:
     
  13. joaoeduardo87

    joaoeduardo87 New Member

    Oct 2, 2007
    0
    Could u please tell me how u fixed this problem thanks.


     
  14. sedated_xtc

    sedated_xtc New Member

    Feb 19, 2009
    0
    Has anybody had this problem where you connect to a wi-fi network, your upside-down 3-tier wifi cone pops up beide your reception bars but when you go to any page on Safari, it says that "Sarfari cannot connect to the requested page because it's not connected to the internet"?

    HELP MAKE THIS GO AWAY! =(
     
  15. dturner

    dturner Zealot
    Gold

    Dec 15, 2007
    12
    Try restarting your phone first. If that doesn't work, go to settings-general-reset-reset network settings.
     
  16. sim

    sim New Member

    Aug 19, 2008
    0
    Make sure your internet connection is live/working.

    I have had two instances lately at home where my Charter cable internet was out. The wifi cone shows because the network is there....just no internet connection.

    Steve
     
  17. dturner

    dturner Zealot
    Gold

    Dec 15, 2007
    12
    (red faced) Yeah, that might be a better first place to start.:eek:
     
  18. PDACPA

    PDACPA Member
    Silver

    Jan 16, 2008
    8
    My iPhone one day came up on the settings page with the grayed out words "no wifi" and obviously no signal.

    The solution was a replacement iPhone from Apple.
     
  19. celebrian

    celebrian New Member

    Feb 11, 2009
    0
    Wifi not working

    I've had this problem over the last two days, wifi works on laptop and desktop computer, network shows up on iPhone but "Safari is not connected to the internet". I've just Restored my iPhone and re-synced it, and everything works again, so you could try that; make sure you back up your settings first.
     
  20. iNinja

    iNinja Zealot
    Gold

    Aug 8, 2008
    18
    I had this problem when the router i was trying to connect to is using WEP encryption. If yours is, change it to WEP 2 and give that a go
     
  21. panzeriti

    panzeriti New Member
    Bronze

    Apr 15, 2009
    0
    Make sure that you are not connecting to a secure network.
     

Share This Page