Wi-Fi used to work, now it doesn't - even though it says it is.

Discussion in 'iPhone' started by motherwell, Aug 13, 2007.

  1. motherwell

    motherwell New Member

    Joined:
    Jun 30, 2007
    Likes Received:
    1
    My Wi-Fi used to work perfectly, but the last few days things have stopped working.

    I am able to select my wireless network (via Apple Airport), and the Wi-Fi menu has a check mark next to my network name, but the Wi-Fi signal does not replace the Edge logo at the top of the screen.

    It's not just a visual problem - my phone is not connected to a wi-fi network, even though it says it is.

    It's not my network either. There is an open wi-fi network within range and I can also select it, but I cannot get an actual signal.

    Along with the issue above, when I go back to my Wi-Fi settings, sometimes Wi-Fi is turned off -- even though it was on about 1 minute ago. Other times I go to the Wi-Fi menu and it says it is on, but there isn't a list of networks to choose from (there are about 10 within range).

    I did a software restore this morning, which didn't help.

    I bought my phone on release day from the ATT store. I probably need to call Apple though? I am not going to be happy if they tell me they can exchange it for a refurbished phone.
     
    #1
  2. hexonxonx

    hexonxonx New Member
    Silver

    Joined:
    Jul 12, 2007
    Likes Received:
    0
    Same thing here, just started happening a few days ago. My two laptops can connect to the network just fine. I just get the message that Safari can't open the page because it can't find the server.
     
    #2
  3. Avatar

    Sponsored Advertisement

  4. motherwell

    motherwell New Member

    Joined:
    Jun 30, 2007
    Likes Received:
    1
    ok I was able to get mine working again. heres what i did:

    turned airplane mode on and off several times (leaving it off for at least 30 seconds)

    Went into settings>general> and found a button to reset the network settings. This caused the phone to reboot. Right after that I turned the phone off and on one more time.

    Then I went and selected my network again. Now its working.

    Hope this helps.
     
    #3
    • Like Like x 1
  5. hexonxonx

    hexonxonx New Member
    Silver

    Joined:
    Jul 12, 2007
    Likes Received:
    0
    Didn't work for me but thanks for the help anyways. Still says Safari can't find the server. Everything else works using wifi just not safari.
     
    #4
  6. ryple333

    ryple333 New Member

    Joined:
    Jul 2, 2007
    Likes Received:
    2
    Whoo hoo! This worked for me too!
    Thanks
     
    #5
  7. USBerliner

    USBerliner New Member

    Joined:
    Mar 3, 2010
    Likes Received:
    0
    I had a very similar problem. When I turned Wifi on my iPhone it wouldn't work, and even made the Wifi on my laptop stop working.

    Try resetting your Airport. I unplugged mine (as well as my phone-since that's where I get my internet from), waited a few minutes, then plugged everything back in. I let Airport boot up again and everything worked again. Good luck!
     
    #6
  8. Datinwangin

    Datinwangin New Member

    Joined:
    Jun 18, 2010
    Likes Received:
    0
    I had the same problem as hexonxonx. my wifi work fine at hotspot area as as in hotel but not at home. My 2 laptop wifi work well. someone Please help.
     
    #7
  9. Raechel Mclain

    Raechel Mclain New Member

    Joined:
    Sep 17, 2011
    Likes Received:
    0
    I would like to just say first off, Thank you to you all for posting these trouble shoots, if it weren't for this we would would be spending boocoo bucks with freakin Apple trying to fix our crap. Now THANK YOU! cause this method above did work. I was detecting a signal but my bars weren't showing up in the status bar... and it would work for a split sec in sarfi and stop. At first this method i tried didn't work but as i dug deeper i found as well with this i rebooted my modem. so the person a few posts down where you say it won't work in safrai. maybe try rebootig your modem. this + the reboot modem worked for me. THANKS ALL! HAPPY IPHONING! :)
     
    #8
Similar Threads
  1. rollinfromhell
    Replies:
    1
    Views:
    2,996
  2. cneltyn
    Replies:
    5
    Views:
    685
  3. sedated_xtc
    Replies:
    7
    Views:
    1,463
  4. iphone62907
    Replies:
    31
    Views:
    52,979
  5. miss tara
    Replies:
    7
    Views:
    713
Loading...

Share This Page