WiFi acting weird.

GLiMKIV

New Member
Bronze
Sep 23, 2007
109
0
0
#1
I am posting for my friend. I have an iPhone and so does he. Except, his WiFi is being really weird. I have shut the phone down and reset the WiFi. Still does not work. Funny thing is, on the main page, the WiFi signal is shown, as soon as he enters Safari, Mail, iTunes (anything that requires data transfer), WiFi stops working and it goes off Edge. Go back to the main screen, the WiFi signal is shown again. He can't send or receive email.

I'm wondering if the only option at this point is to do a full restore. He is on 2.0.1. I will tell him to do the 2.0.2 update and see if that works.

Any recommendations or ideas would be appreciated.
 

liberated

Genius
Gold
Jul 19, 2007
3,238
488
83
#2
Here's how to fix that issue. First run cmd on your desktop machine where the internet connection is coming from. Type ipconfig/all then hit enter. Note the DNS number that will come up (There are going to be many other numbers, you just need the DNS).

1- I have the iPhone connect to the wifi using default DHCP query.
2- After that, change the wifi setting in the iPhone to use the Static mode (DHCP, BootP, and Static modes for each wifi connection)
3-Then fix the DNS address to the DNS address we obtained before.

The problem is solved.
 

GLiMKIV

New Member
Bronze
Sep 23, 2007
109
0
0
#3
Here's how to fix that issue. First run cmd on your desktop machine where the internet connection is coming from. Type ipconfig/all then hit enter. Note the DNS number that will come up (There are going to be many other numbers, you just need the DNS).

1- I have the iPhone connect to the wifi using default DHCP query.
2- After that, change the wifi setting in the iPhone to use the Static mode (DHCP, BootP, and Static modes for each wifi connection)
3-Then fix the DNS address to the DNS address we obtained before.

The problem is solved.
Thanks for the tip. I'll check that out and see if that works.