WiFi does not connect after wake up

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#1
I have my screen set to turn off after 20 minutes of inactivity. I've thought about using a screen saver instead of having the screen go black. Any thoughts? The issue that I'm hoping someone can help is that the wifi will not connect again until I run through the wireless diagnostics and then the connection works. It takes a few minutes before the wifi to connect so if anyone has had a similar issue, would be great to try to get this resolved.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#2
Screen savers aren't necessary. The new screens aren't susceptible to burn in.

Try this:
1. Go to Applications > Utilities > Keychain Access. Delete all entries related to WiFi.
2. Go to System Preferences > Network and delete all WiFi connections by clicking the minus sign.
3. Power off the computer.
4. Reset the PRAM. Power it on while holding the Option, Command, P and R keys. Release the keys after you hear there restart sounds and let it boot.
5. Set up your WiFi after it boots.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#4
I'm still having an issue with the connection. In Network Preferences, it shows that the wifi has a self-assigned IP and will not be able to connect to the internet. I deleted the connection and started over. This one is a mystery and could use any help.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#5
Click the Macintosh HD icon then go to Library > Preferences > and delete the "com.apple.alf.plist" file. Then reboot the MacBook and log back it. Allow the application requests if you get any afterwards.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#6
Click the Macintosh HD icon then go to Library > Preferences > and delete the "com.apple.alf.plist" file. Then reboot the MacBook and log back it. Allow the application requests if you get any afterwards.
I did this last night and it was working for awhile and then quit. After I closed the laptop and went to bed, I tried to get on this morning and the wifi wouldn't connect. I'm thinking it may have something to do with the sleep settings or connection preferences.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#8
It also occurred to me that the wifi is not getting an IP address from the router automatically. I'm keeping the lid on my laptop open until we can figure this out.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#9
Screen savers aren't necessary. The new screens aren't susceptible to burn in.

Try this:
1. Go to Applications > Utilities > Keychain Access. Delete all entries related to WiFi.
2. Go to System Preferences > Network and delete all WiFi connections by clicking the minus sign.
3. Power off the computer.
4. Reset the PRAM. Power it on while holding the Option, Command, P and R keys. Release the keys after you hear there restart sounds and let it boot.
5. Set up your WiFi after it boots.
This is what I did try first and also deleted the certificate in Keychain Access. I removed the connection and set up a new one. When I ran the Wireless Diagnostics, one of the errors was to change the location to Automatic so I did that too. I checked all the settings for the wifi and nothing is our of the ordinary.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#10
I could not figure it out and so I scheduled an appointment with the Genius Bar later that day. He deleted the Library files that were hidden in the Utilities folder and Network Preferences. He also ran diagnostics to see if it was a hardware issue. I brought the laptop back home and eventually connected to the wifi.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,505
113
Utah
#11
I could not figure it out and so I scheduled an appointment with the Genius Bar later that day. He deleted the Library files that were hidden in the Utilities folder and Network Preferences. He also ran diagnostics to see if it was a hardware issue. I brought the laptop back home and eventually connected to the wifi.
Wasn't that the same thing I posted directions for earlier in this thread? Either way, I'm glad to hear it's working for you now.
 

rambo47

Contributor
Silver
Apr 4, 2010
528
79
28
Northern NJ
#12
A restart is always a good step (and free) for sorting out a misbehaving computer.

Also, repairing permissions can clear up some issues. Disk Utility does this but I prefer using the Terminal App (Applications > Utilities > Terminal.App). Open the Terminal and type in:

diskutil repairPermissions /

There is a space after "repairPermissions" and the "P" must be capitalized. I have had filetree issues that prevented the actual Disk Utility app from working. The Terminal always gets it done for me though. Plus it makes you feel like an übergeek. :)