WiFi Help!

justahsquirrel

Member
Silver
Jun 7, 2007
545
0
16
Queens, NY
#1
Well I had my iPhone since launch and as soon as i got it up and running, I connected to my wifi at home that of course is password protected. anyways it works great. all i had to do was come in range of my home wifi and it automaticly did what it had to do. Now...it keeps asking me for my password everytime i come in range or turn on the wifi. anyone know why this is?

Oh yeah, about a software update.....it may come till after the launch of the new OS X....i think that makes sense. cause all the programers are now busy with finishing up OS X since the work on the iPhone is well....just about done...so i think they are going to concentrate on leopard...there just might be a handful of techs working on the iPhone's hickups..........anyways back to my question above...anyone has this happen to them?:mad:
 

ColsTiger

Zealot
Gold
Mar 8, 2007
5,856
2
38
Columbus, GA
#3
Well I had my iPhone since launch and as soon as i got it up and running, I connected to my wifi at home that of course is password protected. anyways it works great. all i had to do was come in range of my home wifi and it automaticly did what it had to do. Now...it keeps asking me for my password everytime i come in range or turn on the wifi. anyone know why this is?

Oh yeah, about a software update.....it may come till after the launch of the new OS X....i think that makes sense. cause all the programers are now busy with finishing up OS X since the work on the iPhone is well....just about done...so i think they are going to concentrate on leopard...there just might be a handful of techs working on the iPhone's hickups..........anyways back to my question above...anyone has this happen to them?:mad:
It might have something to do with your network. Is it WEP secured or unsecured? If it's unsecured, then it might be wanting to connect to another unsecured network in the vicinity.
 
Jun 7, 2007
545
0
16
Queens, NY
#4
It might have something to do with your network. Is it WEP secured or unsecured? If it's unsecured, then it might be wanting to connect to another unsecured network in the vicinity.
its a secured network and it keeps asking for the password. it worked fine before...it didn't ask for it before..only the first time i entered it...then for a week it worked fine...then all of a sudden it keeps asking for the password..fliping weird man.
 

cdgloria

New Member
Nov 11, 2007
7
0
0
#5
can anyone help me?
my new bought iPhone, all of sudden, the wifi under setting turned blurred
and shown "NO WIFI" i did try to reboot, but can't help.

my problem is, i had my iPhone unlocked.
I worry if i take it back to Apple store, they would reject my request since i didn't sign up for AT&T. because I called the 1-800-MY-APPLE for tech support,
the guy had to get my AT&T number in order to solve my problem.

what can i do?
 

iStealth

Member
Bronze
Nov 5, 2007
421
0
16
#6
can anyone help me?
my new bought iPhone, all of sudden, the wifi under setting turned blurred
and shown "NO WIFI" i did try to reboot, but can't help.

my problem is, i had my iPhone unlocked.
I worry if i take it back to Apple store, they would reject my request since i didn't sign up for AT&T. because I called the 1-800-MY-APPLE for tech support,
the guy had to get my AT&T number in order to solve my problem.

what can i do?
Have you checked the wifi access point (router) to see if that is ok, or that your wifi is even on (on you iPhone)? On the Ipod touch I have an on/off switch for wifi under "settings"
 

cdgloria

New Member
Nov 11, 2007
7
0
0
#7
ohoh.... i got the solution of my problem

how?

all i did, just to erase all my safari's cache, and history and reboot my iPhone.

it's BACK!
 

cdgloria

New Member
Nov 11, 2007
7
0
0
#12
it has nothing to do with my router, but my iPhone
i'm using a 1.1.1 version,
but if restore in iTune, do i have to RE-activite and Unlock it again?

it's weird... that losing the Wi-Fi wasn;t too big deal for me, but the battery would drain dramatically from, 2 days to 6 hrs

:mad:
 

iStealth

Member
Bronze
Nov 5, 2007
421
0
16
#13
it has nothing to do with my router, but my iPhone
i'm using a 1.1.1 version,
but if restore in iTune, do i have to RE-activite and Unlock it again?

it's weird... that losing the Wi-Fi wasn;t too big deal for me, but the battery would drain dramatically from, 2 days to 6 hrs

:mad:
I would imagine you would have to unlock again if you restore in iTunes. If you are worried about wifi draining your battery, just switch it off, and it won't look for a signal.. I know the touch has this ability, I would imagine the iPhone does also?
 

cdgloria

New Member
Nov 11, 2007
7
0
0
#14
my problem is WiFi is greyed! switching off is not an option.

But, in my iPhone's normal days, even I switched on all day long, the battery was normally run.

but I found one thing, this Wifi OUT were happened right after come back from a place required roaming.
 

Kevin77

New Member
Nov 17, 2007
4
0
0
#15
it has nothing to do with my router, but my iPhone
i'm using a 1.1.1 version,
but if restore in iTune, do i have to RE-activite and Unlock it again?

it's weird... that losing the Wi-Fi wasn;t too big deal for me, but the battery would drain dramatically from, 2 days to 6 hrs

:mad:
Hi Gloria,

My WiFi broke down on my iPod Touch. It was working OK one morning, I watched a 30 minute video, and when I went back into Safari I couldn't. I checked the WiFi settings and it was grayed out. I rebooted, restored, reset, etc., and nothing fixed the problem. Apple said it was a hardware problem, and yes my battery also rapidly exhausted all power during the "no WiFi" problem. It's as if the unit was continuously trying to get the WiFi to work or maybe there's some sort of circuitry that has something to do with the battery that also breaks the WiFi. It's definitely some bug in the hardware of the iPhone/iPod Touch.
 
Oct 4, 2007
5
0
0
cali
#16
ok ive had my iPhone for a while now, and ive been able to connect to everywhere but my house, kinda gay, but my phone will see the connection, itll say its on but my E never goes away and when i look at the settings under my connection the DNS, Client ID, and Search Domains are empty(with something to fill in i guess?) so does anyone know how i can get this stupid thing to work? or where i find the information i need to fill in? cause now i need my connection at home, thanks!
 

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#17
First try reseting both the phone and your router. Of that doesn't work, make sure your router's settings aren'tessed up and do a Restore in iTunes.

- John
 

ColsTiger

Zealot
Gold
Mar 8, 2007
5,856
2
38
Columbus, GA
#18
ok ive had my iPhone for a while now, and ive been able to connect to everywhere but my house, kinda gay, but my phone will see the connection, itll say its on but my E never goes away and when i look at the settings under my connection the DNS, Client ID, and Search Domains are empty(with something to fill in i guess?) so does anyone know how i can get this stupid thing to work? or where i find the information i need to fill in? cause now i need my connection at home, thanks!
You shouldn't have to do anything except key in your wifi router's passkey. If you've messed with the settings, then you might want to do a full restore and start fresh. IF your wifi is working for your laptop, it should work for you iPhone. You should get a Wifi Available window pop open, and then be prompted to key in the passkey.