WiFi is not working, help please

Nov 16, 2007
24
0
0
#1
Hey everyone. I have a problem with my wifi on my iPhone. it shows it is connected to my network in the settings but when i jump on the web, youtube, and installer.app it defaults back to edge. I know its not because of the jailbreak because i had the same problem before i jailbroke the iPhone. The only reason i really care is because downloading things from installer.app takes forever! on edge

Help would be greatly appreciated.
thanks in advance
 

themanofthedark

New Member
Gold
Jan 5, 2008
2,674
0
0
25
Boston
#2
what is the signal strength? it may be really weak, and your iPhone loses it.
 

IphoneTony

Zealot
Gold
Nov 10, 2007
2,163
18
38
37
New Jersey
#3
Is it your home wifi? Most likely its low strength I have this happen to me when I am away from my home wifi and im connected to wifi at work... or at the mall
 
Nov 16, 2007
24
0
0
#4
it shows full strength . ive heard that theres something called a MAC address that my be conflicting with it. any ideas?
 

patrickj

Genius
Gold
Sep 2, 2007
6,221
445
83
Austin, Tx
ipadinsight.com
#5
it shows full strength . ive heard that theres something called a MAC address that my be conflicting with it. any ideas?
A MAC address is a unique identifier for a PC network card or just about any networkable device, like the iPhone in this case. Probably what you've heard people talking about is that you can set your home WiFi router to 'restrict by MAC address', meaning that only devices with addresses that are specifically entered into your router are allowed to connect to the network.

If that were the case, and the iPhone's MAC address was not entered on your router, it would never connect, instead of the connect and drop symptoms that you seem to have - and also you (or whoever sets up your home router) would know if you were restricting by MAC address.

Does your phone stay connected to any WiFi network? If you haven't yet, I would try connecting at an open public hotspot - if you get same symptoms, would be worth doing a reset of all network settings, and maybe a restore after that ...
 
Nov 16, 2007
24
0
0
#6
thank you for the insight. It does show that it stays connected so im assuming from what you have said that it is not the MAC address. I think tomorrow ill go to starbucks or something and see if it works there. I have an older linksys router. Do you think that it is possible that the router could be too old so it may not be compatible with the iPhone?
 

patrickj

Genius
Gold
Sep 2, 2007
6,221
445
83
Austin, Tx
ipadinsight.com
#7
thank you for the insight. It does show that it stays connected so im assuming from what you have said that it is not the MAC address. I think tomorrow ill go to starbucks or something and see if it works there. I have an older linksys router. Do you think that it is possible that the router could be too old so it may not be compatible with the iPhone?
I doubt that there is a compatibility issue with the router, if it allows you to connect. Do other devices - a laptop or PC at home - connect OK to your WiFi network.

And yeah, definitely think you should give it a shot at a public place, or even better a couple of open hotspots - and see if you get same symptoms. If you do, try the reset of settings and then a restore. If problem persists after that, you'd want to take it to an Apple Store if possible or talk to Apple in any case ....
 
Nov 16, 2007
24
0
0
#8
my dads dell laptop connects via wifi and im on a imac right now that is connect via a wifi. if by chance my phone needs to be replaced. if i restore my iPhone before i take it in (beacause its jailbroken) will they have any chance of knowing i did and thus voiding my warranty?
 

patrickj

Genius
Gold
Sep 2, 2007
6,221
445
83
Austin, Tx
ipadinsight.com
#9
my dads dell laptop connects via wifi and im on a imac right now that is connect via a wifi. if by chance my phone needs to be replaced. if i restore my iPhone before i take it in (beacause its jailbroken) will they have any chance of knowing i did and thus voiding my warranty?
Ok, so test at a couple other hotspots.
On the warranty subject, if you do a full restore and if you're not showing any customized carrier logos etc after restore (if you are see other threads here for how to get rid of those) then chances are slim that you have any worries when taking it in, I think ...