WiFi Reconnect Slow or Doesn't Happen on iPhone 4S

Nrevezzo

Member
Bronze
Apr 15, 2009
104
23
18
Canton, Mi
#1
Since upgrading to iOS 7 on my iPhone 4s it takes a few minutes to reconnect to my home WiFi when returning from being out. Sometimes it won't reconnect until I enter the WiFi settings screen. I tried removing and re-adding the network connection but that did not resolve the problem.
Has anyone else experienced this issue?
 

RBNetEngr

Contributor
Bronze
Jun 17, 2013
171
27
28
#2
Yes, I've experienced it a few times. As you said, opening the Settings screen, turning wifi off and then on will make it reconnect.

It's not a regularly occurring problem, so I have not been able to figure out a pattern. I used the phone on wifi all evening, and then when I tried a few hours later, it would not automatically reconnect.


-rb
 

Nrevezzo

Member
Bronze
Apr 15, 2009
104
23
18
Canton, Mi
#3
I deleted the connection(Forget Network) again, restarted my phone, and restarted my router. Then recreated the connection except I identified the security as WPA instead of WPA2. So far this seems to have resolved the problem.
 

RBNetEngr

Contributor
Bronze
Jun 17, 2013
171
27
28
#4
I deleted the connection(Forget Network) again, restarted my phone, and restarted my router. Then recreated the connection except I identified the security as WPA instead of WPA2. So far this seems to have resolved the problem.
WPA is less secure than WPA2. But it's not clear whether you're saying you just changed your phone to WPA, or your phone and router. You should use the most secure connection for wireless.


-rb
 

Nrevezzo

Member
Bronze
Apr 15, 2009
104
23
18
Canton, Mi
#5
I only changed to WPA on my phone. The router is/was set to WPA/WPA2 so I guess that's why it works.
I since changed my router to be WPA2 only and allow G and N connections. Previously the router allowed B, G and N.
My phone is now WPA2 also.
This setup is working well.