WiFi signal does not turn off

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#1
I use WiFI at my house for both my Mac and iPhone. The problem is that when I leave the house in the morning for college, my WiFi signal is still active and draining my battery. Is there a setting where when my WiFi is out of range, my network will switch over to 4G? I've looked through all the network settings for the WiFi connections.
 
Dec 15, 2008
5,386
340
83
27
Pensacola, FL
#2
It should already automatically do that. Mine switches to no signal as I don't want to use cellular data. It'll then go back on wifi if it recognizes a wifi connection. Have you tried any steps such as resetting your settings?

Are you saying that your phone believes that the signal is still but goes in and out?
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#3
It should already automatically do that. Mine switches to no signal as I don't want to use cellular data. It'll then go back on wifi if it recognizes a wifi connection. Have you tried any steps such as resetting your settings?

Are you saying that your phone believes that the signal is still but goes in and out?
I reset my home network and settings on my phone. The phone still thinks that I'm connected to Wi-Fi when I'm outside of my house. It's not switching over to 4g.
 
Dec 15, 2008
5,386
340
83
27
Pensacola, FL
#4
I reset my home network and settings on my phone. The phone still thinks that I'm connected to Wi-Fi when I'm outside of my house. It's not switching over to 4g.
This is a first of hearing this issue of course. Have you tried other steps? I'm just thinking here. How about a full reboot of your home wifi system?

When did this start? Are you on the latest ios? I know Macbook Pro is having wifi issues but this is the iPhone.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#6
I think I've figured out what is going on. If I'm within range of a Wi-Fi signal, my phone automatically connects to the Wi-Fi. That is why my Wi-Fi is always on. So is there a way to stop the phone from connecting to a network and staying connected? I believe I've turned off "Automatically join networks" in Settings->Wi-Fi.
 

RBNetEngr

Contributor
Bronze
Jun 17, 2013
170
27
28
#8
I think I've figured out what is going on. If I'm within range of a Wi-Fi signal, my phone automatically connects to the Wi-Fi. That is why my Wi-Fi is always on. So is there a way to stop the phone from connecting to a network and staying connected? I believe I've turned off "Automatically join networks" in Settings->Wi-Fi.
Your phone should only connect to a wifi network automatically if you have that wifi network added to your phone. First of all, find out what it is, because for it to always be in range with your phone, it's probably something else you're carrying around with you, like a mifi unit, or another phone or computer with an adhoc wifi network enabled.

Look at your iPhone to see the name of the network you're connecting to when you're away from home to give you a clue what it is. If it's a network you shouldn't connect to, go into your wifi settings, select the 'I' next to the network you're connected to, and select 'Forget this Network'. Or, change the settings to no longer automatically connect to it.
ImageUploadedByiCafe Forums1416016923.545468.jpg


-rb
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#9
I didn't reset the network settings on my phone yet. I'm saving that as a last resort.
I do it all the time. It's a simple fix for a lot of cellular/WiFi problems. It's not time consuming to set back up like a factory restore. You just have to put your wifi passwords back in. It's a piece of cake.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#11
Hope I am not Capt. Obvious here, but I did not see this yet...did you try control center, wifi off?
That's not a solution to the problem. You shouldn't have to toggle WiFi off when you leave the range of a network. It should automatically disconnect and then reconnect when you're back in range. Resetting the network settings should fix it, but he didn't want to try that for some reason. If not, the next step would be resetting all settings.
 

iPutz

Zealot
Silver
Nov 20, 2012
950
184
43
71
US Midwest
#12
Resetting network settings as Europa suggested can fix a multitude of issues including yours. I have had to do it several times in the last year so now I keep a list of WiFi networks and passwords I've connected to in the past right in my phone. Like the Lady said, it's a piece of cake.


If it ain't broke, don't fix it!!

Sent from my iPhone 6
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#13
Resetting network settings as Europa suggested can fix a multitude of issues including yours. I have had to do it several times in the last year so now I keep a list of WiFi networks and passwords I've connected to in the past right in my phone. Like the Lady said, it's a piece of cake.


If it ain't broke, don't fix it!!

Sent from my iPhone 6
I'm still having this issue. The wifi remains active when I leave the house and it is affecting battery life. There doesn't appear to be a way to shut it off. I have to turn the Wi-Fi off through Control Center. It stays constantly connected. I reset my network settings. When I'm at home, my network automatically switches over to Wi-Fi from 4G. Does anyone else have this issue?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#14
I'm still having this issue. The wifi remains active when I leave the house and it is affecting battery life. There doesn't appear to be a way to shut it off. I have to turn the Wi-Fi off through Control Center. It stays constantly connected. I reset my network settings. When I'm at home, my network automatically switches over to Wi-Fi from 4G. Does anyone else have this issue?
I've never heard of that particular problem. Did you reset your network settings?
 

coop1701

Zealot
Silver
Jun 30, 2007
899
113
43
#15
I've never heard of this either, Make you wonder what his cellular settings look like.
I would certainly do what Europa Suggested though. I have seen doing that reset fix a lot of things.
 

iPutz

Zealot
Silver
Nov 20, 2012
950
184
43
71
US Midwest
#16
After you have left home what is the WiFi network that the phone shows you are connected to, your home network or some other one? I know when I leave home my phone will show that it has switched to the cellular network within a few seconds of losing my home WiFi signal since there are no other WiFi signals available. Something I just thought of, and admittedly this is a bit off the wall, once you know you're out of range of the offending network, try tapping the circled "i" next to the network's name and then tap on "Forget This Network". Once you return to that network's coverage area set it up again and see what happens when you go out of range the next time. If resetting your network settings, hard reset etc. haven't worked the last resort would be to back-up your phone in iTunes then restore it as new and see if that restores proper function. If the phone is working correctly at that point try restoring from the backup you previously did in iTunes and see what happens. Good Luck.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#17
I've never heard of that particular problem. Did you reset your network settings?
I did reset my network settings. I'm thinking that when I get out of range, it's switching over to cellular but what I see in the Control Center is that the Wi-Fi icon is still illuminated so I'm believing that my Wi-Fi is constantly running when in fact it might be normal behavior.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#18
After you have left home what is the WiFi network that the phone shows you are connected to, your home network or some other one? I know when I leave home my phone will show that it has switched to the cellular network within a few seconds of losing my home WiFi signal since there are no other WiFi signals available. Something I just thought of, and admittedly this is a bit off the wall, once you know you're out of range of the offending network, try tapping the circled "i" next to the network's name and then tap on "Forget This Network". Once you return to that network's coverage area set it up again and see what happens when you go out of range the next time. If resetting your network settings, hard reset etc. haven't worked the last resort would be to back-up your phone in iTunes then restore it as new and see if that restores proper function. If the phone is working correctly at that point try restoring from the backup you previously did in iTunes and see what happens. Good Luck.
I like this suggestion and will try it next time I'm out of range.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#20
I did reset my network settings. I'm thinking that when I get out of range, it's switching over to cellular but what I see in the Control Center is that the Wi-Fi icon is still illuminated so I'm believing that my Wi-Fi is constantly running when in fact it might be normal behavior.
So it says LTE or 4G in your status bar and not the WiFi symbol after you leave your house? That means you are no longer connected to WiFi.

What you are seeing in Control Center is just a toggle. It just shows WiFi is enabled. It does NOT mean you are connected to WiFi.

We completely misunderstood you. Your phone is fine.