Winscp

Discussion in 'iOS Software' started by ob123, Aug 18, 2007.

  1. ob123

    ob123 New Member
    Bronze

    Joined:
    Jul 3, 2007
    Likes Received:
    0
    I have jailbreak running but when i try to run winscp i get this
    [​IMG]
    my firewall is off.
    i have ssh running
    i have seen other people have had this problem but have not found an answer please help!
     
  2. sublime

    sublime New Member

    Joined:
    Aug 18, 2007
    Likes Received:
    0
    Security Program Running

    I had the same problem then I found out that norton anti virus/firewall was the problem. I uninstalled all norton application and it is now working fine.


     
  3. ob123

    ob123 New Member
    Bronze

    Joined:
    Jul 3, 2007
    Likes Received:
    0
    ya i uninstalled norton and im still getting the same problem, is there another program i can use instead of this?
     
  4. x999x

    x999x New Member
    Gold

    Joined:
    Aug 6, 2007
    Likes Received:
    0
    If you've got a firewall or router, make sure you've got port 22 open. You may also need to port forward port 22 to your desktop's IP address.

    22 should be open already, but if you're having problems, it's worth a shot.
     
  5. soulracerdc2

    soulracerdc2 New Member

    Joined:
    Jul 5, 2007
    Likes Received:
    0
    Please Help! THanks

    Im trying to install NES on my phone. I got this link(http://hacktheiPhone.com/iPhone_install_nintendo_emulator_windows.html)

    Its a step by step guide to install NES. But now im stuck on the "WinSCP" part. I can't log in. I read somewhere on my phone i can find the ip address on the static tab but its not there. I tried logging in wit User:root Pass:dottie. I also tried alpine.

    Please help, I don't know what im doing wrong.

    Thanks in advance!:laugh2:
     
  6. Kathie63

    Kathie63 Member
    Bronze

    Joined:
    Mar 15, 2009
    Likes Received:
    1
    I just got the 3GS and jb it today but when I try to get into winSCP it won't let me connect. it tells me network error:connection refused

    When I had my 3g I had no problems what so ever. I do have the correct IP address and user name and password, same as before. HELP
     
  7. iphonewarrior

    iphonewarrior Moderator
    Moderator

    Joined:
    Apr 11, 2008
    Likes Received:
    701
    Do you definitely have openSSH installed..? lol. :sneaky:

    PW: alpine
     
  8. Kathie63

    Kathie63 Member
    Bronze

    Joined:
    Mar 15, 2009
    Likes Received:
    1
    Yes I have used it many times with my 3g. I have winSCP installed

    I have the protocol set to SCP
     
  9. patrickj

    patrickj Genius
    Gold

    Joined:
    Sep 2, 2007
    Likes Received:
    445
    If OpenSSH is installed, have you also used SB Settings or similar to make sure it is turned on?
     
  10. Kathie63

    Kathie63 Member
    Bronze

    Joined:
    Mar 15, 2009
    Likes Received:
    1
    yes everything is ok with ssh. still not connecting
     
  11. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    4,470
    Wifi is on and the iPhone is not locked?
     
  12. Kathie63

    Kathie63 Member
    Bronze

    Joined:
    Mar 15, 2009
    Likes Received:
    1
    wifi is connected and phone is unlocked
     
  13. patrickj

    patrickj Genius
    Gold

    Joined:
    Sep 2, 2007
    Likes Received:
    445
    I did a post on this at my site a while back with a little troubleshooting checklist. Might not be of help for you, but just in case ...

    Things To Try If You Cannot Connect To Your iPhone Via SSH:

    • If you get a timeout error, try increasing the timeout setting
    • Make sure SSH is turned on, on the iPhone - Generally the easiest way to do this is to use an app like SB Settings that gives you a GUI interface to toggle the service on and off with.
    • Make sure WiFi is turned on, on the iPhone – again, via SB Settings or the iPhone’s built-in Settings Applet.
    • Check that you are specifying the right port in your desktop SSH app (e.g. WinSCP on Windows or Cyberduck on Mac). The port needs to be 22.
    • Make sure you are entering the correct – and *current* – IP address for the iPhone. If your iPhone gets a DHCP (dynamically configured) IP address from your router (as most do), then its address can and will change over time. So its IP address today may be different to the one it had last week when you last successfuly connected. To check this go to Settings > WiFi – and tap on the blue arrow next to your active WiFi connection – the screen that takes you to will display the iPhone’s current IP address.
    • Verify that the iPhone has a *valid* IP address. When you are checking the address per the above point, if you see an address that starts with 169.254.x then the iPhone is not getting a usable IP address – and you need to troubleshoot that issue first.
    • Remember that the iPhone and the PC you’re tying to connect from must be on the same WiFi network. One of the easiest ways to tell this is to see if their IP addresses look similar. For instance, many default home WiFi networks will have IP addresses that start with 192.168.x.
    • Check that you do not have any antivirus, firewall, or security software on your PC that may be blocking your outbound SSH connection. One of the easiest ways to quickly rule this out (or pin the blame on it) is to shut down any and all of those services on your PC temporarily and try connecting. If it still fails, you know those services are not to blame.
    • Password check – you need to be using the correct username and password for connection to the iPhone. If you have never changed these (which the vast majority of iPhone users have not – and you would know if you did) then the most likely defaults are username ‘root’ and password either ‘alpine’ or ‘dottie’. Please note – you do not type the ‘’ inverted commas around the username or password.
    • The iPhone cannot be in ‘sleep mode’ when you are trying to connect. You may just want to change your Auto-Lock setting to ‘Never’ just for while you are connecting – to avoid this issue.
    • Make sure you are using the correct protocol setting in your desktop SSH app. This varies according to which client app you are using. WinSCP uses SCP, for example.
     
  14. Kathie63

    Kathie63 Member
    Bronze

    Joined:
    Mar 15, 2009
    Likes Received:
    1
    I looked on my phone for the ip address and the computer, the addresses are the same except for the last number. the computer has 11 and the phone has 13 otherwise the address is the same. where do I find the SSH on my phone?
     
  15. patrickj

    patrickj Genius
    Gold

    Joined:
    Sep 2, 2007
    Likes Received:
    445
    Have you rebooted the iPhone? Rebooted the PC?
     
  16. Kathie63

    Kathie63 Member
    Bronze

    Joined:
    Mar 15, 2009
    Likes Received:
    1
    I just got done doing that. this is frustrating, when it has worked since March
     
  17. BrownGem

    BrownGem Zealot
    Gold

    Joined:
    Feb 27, 2009
    Likes Received:
    22
    Have you tried connecting with your router security off?
     
  18. partizan

    partizan Member
    Bronze

    Joined:
    Feb 25, 2008
    Likes Received:
    3
    If you have iTunes installed on that particular machine, you can always use the iPhonebrowser.
     
  19. Kathie63

    Kathie63 Member
    Bronze

    Joined:
    Mar 15, 2009
    Likes Received:
    1
    I have tried everything it seems still can't get in. I give up
     
  20. iErik

    iErik Zealot
    Gold

    Joined:
    Oct 27, 2007
    Likes Received:
    72
    Make your file protocol SFTP and uncheck "allow SCP fallback". That's what I had to do to get it to work.
     
Similar Threads
  1. iphoneluverr
    Replies:
    4
    Views:
    877
  2. neo_gr8est1
    Replies:
    13
    Views:
    2,901
Loading...

Share This Page