Search results

  1. Eddy Jay

    Updates iPhone 3G

    Thanks a lot "Fearofnormalcy" for that info. How can I install apps? Almost all apps I come across seem to be requiring 4.3 and above. Any advice?
  2. Eddy Jay

    Updates iPhone 3G

    I have an iPhone that is currently running iOS 4.1.2. I'm starting to run into compatibility issues with apps and would like to find a way to update to iOS 4.3 and above from 4.1.2. Is this possible?