3GS iPhone Problem! Help is appreciated!


New Member
Jul 20, 2011
Hello, i am quite new to this forum (first thread/post)!

Before i begin, i did do research and found multiple solutions for each of my different problems, but none of them have worked thus far and i believe it is because I have a unique set of problems going on all at the same time!

First off it is a 32GB 3GS, it had 4.2.1 FW and 5.15.04 baseband to begin with. I wanted to jailbreak/unlock so i used redsn0w 0.9.6b5. It has the old bootrom. I always have problems when trying to load cydia and the ipad bb at the same time, so i started by loading the ipad bb first. Everything looked normal until it was wrapping up and started the reboot process. When i was waiting for the home screen to load i noticed it was taking a while for it to load and the Apple logo stayed. Then all of a sudden it restarted as if it was trying again. It then entered a reboot loop, taking about 10 seconds between each reboot! When researching i only find ones that were rebooting every few minutes.

I tried a few different methods including, holding power and home combo buttons then plugging into iTunes. None of which seemed to work it just continuously went to the reboot loop. After i finally got it in restore mode, i tried to load 4.2.1 back onto the phone. Since the ipad baseband was probably already loaded onto it, it rejected the restore.

I then proceeded to just update to the latest firmware (4.3.4) just to cut my loses and wait until this version was unlockable. Everything went according to plan until the end, the iPhone powered off and i got error 1015 from iTunes!

Now i am lost as to what i need to do! If anyone at all can help me i would be forever grateful!


Feb 16, 2010
Burnley, UK
Because you put the ipad bb on, you have to restore to custom firmware (not official), are you using a mac or a pc?

If using a mac then you can create a fw in pwnage tool and use that to restore your phone. If you're using a pc then use snowbreeze.