"device not eligible" - restore error. tried EVERY fix i could find, no gs.Apple line in hosts!


New Member
Apr 10, 2011
i have been trawling the internet for hours now trying to find a fix for my iPhone 4 firmware 4.2.1. i jailbroke my iPhone about 3 weeks ago and it started acting up...i could no longer download or update anything from the app store, or do anything with them on iTunes. finally after dealing with what i had on my phone i decided to just restore my phone back to new and start again. however, i ran into this error when trying to restore through iTunes. i did the whole "shift" restore option and used an ipsw from felixbruns so that i could re-jailbreak using jailbreakme this time! i've searched everything i can find, and i'm now hoping someone could help my problems directly. i have also tried restoring on another laptop to which it gave me a different error of 3194. both fail at the end of the extraction of the firmware.
any suggestions?


Senior Moderator
Dec 12, 2008
Apple only allows restoring to the latest firmware, which is 4.3.5. If you try to restore to anything else, you'll get an
Device not eligible for the requested build error. There is a way to circumvent this error, but you have to save an SHSH for the device prior to Apple's signing window closing. It closes on or around the day a new firmware is released.

Did you backup your 4.2.1 SHSH? The deadline was in March. If you have this, you can downgrade with TinyUmbrella or edit your hosts file and add in Saurik's server before shift+restoring, but anticipate at 10xx error at the end of the restore. You can kick it out of recovery mode with TinyUmbrella or RecBoot.