How I screwed up my iPhone. HELP NEEDED.


New Member
Jul 20, 2011
Okay, so I really need some help/advice. I bought an iPhone 3gs and it was on 3.1.3 firmware. I'm on T-Mobile, so I got straight to jailbreaking it. I jailbroke it with Spirit and it was really fast and insanely easy. Then I got on Cydia and installed blackra1n to unlock it. It completed and said that the download was done but there was a popup saying that it was updating the data that didn't let me do anything. So I left it for a while, but then turned off the phone. When I turned it back on, it went to the Apple logo then a white loading bar with the Apple aurora background. It filled the loading bar completey, but still hadnt changed. So I left it for a while again. When I look back at it, it was on the same screenshot. So I turned it off and on again. But this time, it only went as far as the Apple logo. I did this two more times with the same result. I tried to fix by putting in recovery mode. I plugged it into iTunes but to restore it, i'd have to update it to 4.3.4. I know that i could jailbreak 4.3.4 with redsn0w or pwnagetool. But i'm afraid that it would change my baseband to 4.3.4 and I know that there is no unlock for that baseband. So now I don't know if i should let iTunes update it and risk trying to unlock it or if i should downgrade it as soon as it updates. (but downgrading looks really complicated and im not sure if i can do that) Or maybe there's a way to fix it without updating it? HELP! - first post.

Still having problems. I tried to save the 3.1.3 shsh blobs since i haven't restored it yet. I downloaded tinyumbrella, but my device just wouldn't show up. So i downloaded Autoshsh. I went through all the steps and at the end it asked me to pick a file location so i put it in my documents. after i pressed save, two popups showed. One saying that i was done and that it should be saved in my location and saved on cydia. and onether from java saying that an error occurred and that it wasn't able to open it. So i did this twice more to the same result. I don't know if the shsh blobs are really saved and if its okay to restore it because i can downgrade it with my "save" shsh blobs. I just downloaded ifaith. I don't know what my next move should be? - second post.

did everything there was to do on ifaith.

i keep trying to restore to the original 3.1.3 with iTunes using and "signed" ipsw from ifaith. The iPhone 3gs is in constant black screen(pwned DFU mode) and the Apple logo/loading bar pops up when Apple is "verifying". When the restore is complete, it tells me to leave it plugged in and that it should be restarting now. There's a little 10 second countdown then the pop goes away and im back where I started, iTunes recognizes an iPhone in "recovery mode". -_____- HELP. - third post.

Now if ANYONE has any advice or tips or things they think i should do, they would all be GREATLY appreciated.

UPDATE: I tried ireb and tinyumbrella. didn't work. Nothing works. Please help or refer to service that could.