iPhone 3G iOS 3.1.3


New Member
Apr 10, 2012
Greensboro, North Carolina
I have the device above. It is currently iOS 3.1.3 but originally it was 4.2.1. My operating system is windows 7 64-bit.
At first i tried to jailbreak it with redsn0w and then i downloaded ultrasn0w off cydia but it did not work. I researched s'more and found that the iPad bb was also required. With further research an unreliable source told me to "deactivate" the phone. Ignorant as I was, I followed these steps and managed to overheat and break the touchscreen wires. I cracked the phone open and managed to fix it. I restored it with iTunes afterwards( signaling that perhaps the iPad bb installation was faulty). I retried to unlock and jailbreak it afterwards but with no avail, it still said no service( at this point iPad bb was installed). Then it went to recovery mode with the slide for emergency call and was stuck. I managed to bypass this buffer with a restore to a custom ipsw created by sn0wbreeze 2.2 with ultrasn0w packaged along. Still fruitless. I researched more and i found that 4.2.1 was incredulously slow and laggy so i tried to downgrade to a hacktivated 3.1.3 iOS. Following that mistake, the iPhone went into a recovery mode loop and no matter how i restore ( to custom or restore ipsws) it always gives an error whether 21, 10xx,16xx) I tried to exit recovery mode with tinyumbrella and it always returned to that page. I tried to place the phone into DFU mode and fix recovery then afterwards restore to factory settings on iTunes, however nothing seemed to have result. Btw all my restores after the getting stuck with the recovery mode have been tried in dfu, pwned dfu, and recovery mode. I tried to use an older version of redsn0w 0.9.4 to jailbreak it and somehow get pass the recovery mode loop but it seemed always to get stuck on the downloading jailbreak data with a loading circle beneath it( i always used ipsw for 3.1.2 instead of 3.1.3 because redsn0w does not recognize 3.1.3). ( redsn0w.exe is closed at this step) Right now it is partially restored to factory settings but it is still recognized by iTunes as 3.1.3. Help? >.< My aim is to jailbreak it hopefully back to 4.2.1 as some say 4.xx and above allow access to some third-party apps in cydia not available to firmwares like 3.1.3 . Then to unlock it. ( I have a T-mobile sim card.
  • Like
Reactions: fijiman


Feb 13, 2011
If you managed to install the iPad baseband it will always require a custom firmware build from now on....even if you put it back to stock...