iPhone 3G WiFi problem please help

kaoz_303

New Member
Nov 26, 2009
4
0
0
My iPhone has been working with the internet until the 3.1 update and now it cant connect to the internet it always says "Unable to Join". I have tried resetting but that hasn't worked. i found an Apple page "Tips whem using wifi" where it said to Renew Lease, but my iPhone doesn't even have that button. So i don't know what to do please help!
 

iNinja

Zealot
Gold
Aug 8, 2008
3,987
21
38
UK
To renew your lease, in the WIFI page, tap the blue arrow on the right hand side of the wifi your trying to connect to.

Your then able to renew your lease, however I doubt this will fix your problem. Try to reset your network settings in settings.
 

kaoz_303

New Member
Nov 26, 2009
4
0
0
I just said that

i just said that i tried resseting the network setting and that doesn't help at all....and ya i know i tapped the blue arrow but that renew lease is not there at all
 

iNinja

Zealot
Gold
Aug 8, 2008
3,987
21
38
UK
i just said that i tried resseting the network setting and that doesn't help at all....and ya i know i tapped the blue arrow but that renew lease is not there at all
You didn't say you tried resetting network settings, you said you tried resetting.

Also, if the renew lease isn't showing, I don't think ,you have connected to the WIFI network properly.
 

kaoz_303

New Member
Nov 26, 2009
4
0
0
oh ok my bad

well yes i tried resseting the network settings
but well then how do i connect it correctly? it was working before so what coukd be the problem now? i pressed into the blue arrow and for sum reason i CAN'T tap into the Ip Address, Subent mask or ROuter....i can only tap into the DNS. please help me out
 

computerfox

Zealot
Gold
Oct 2, 2009
3,550
10
38
New Jersey
www.abelgancsos.com
My iPhone has been working with the internet until the 3.1 update and now it cant connect to the internet it always says "Unable to Join". I have tried resetting but that hasn't worked. i found an Apple page "Tips whem using wifi" where it said to Renew Lease, but my iPhone doesn't even have that button. So i don't know what to do please help!
your problem is actually very common. the proper way to fix it is to update to 3.1.2 since it fixes many of the bugs in 3.1.

what do you mean "correctly" usually you go into the networks being broadcasted (just go into settings and you'll see) then connect. it should work, but i would highly recommend updating the firmware to fix the rest of the bugs in 3.1.