iTunes error 14 while upgrading iPhone 3GS


Jun 21, 2009
Wichita Falls, Texas
I updated my iPhone 4 with. I problem.

On my wife's iPhone 3GS I get an error 14. Have tried all the troubleshooting on the Apple site with no dice. Redownloaded the software with same result. Have tried to google it with no luck.

Any advice or insight from the gurus here?


Dec 2, 2007
Long Island, NY
Error 13 and 14: These errors are typically resolved by performing one or more of the steps listed below:
  1. Perform USB isolation troubleshooting, including trying a different USB port directly on the computer. See the advanced steps below for USB troubleshooting.
  2. Put a USB 2.0 hub between the device and the computer.
  3. Try a different USB 30-pin dock-connector cable.
  4. Eliminate third-party security software conflicts.
  5. There may be third-party software installed that modifies your default packet size in Windows by inserting one or more TcpWindowSize entries into your registry. Your default packet size being set incorrectly can cause this error. Contact the manufacturer of the software that installed the packet-size modification for assistance. Or, follow this article by Microsoft: How to reset Internet Protocol (TCP/IP) to reset the packet size back to the default for Windows.
  6. Connect your computer directly to your Internet source, bypassing any routers, hubs, or switches. You may need to restart your computer and modem to get online.
  7. Try to restore from another known-good computer and network.


New Member
Jan 26, 2012
New Orleans, Louisiana
I'm running into the same problem, on my hackintosh, I suppose my desktop suppose to have more power to the usb connections. Tried on Snow Leopard with latest itune trying to update my 3GS straight to 5.0.1 without custom fw. same error 14 on windows 7 running parallel. So I try the 4th time on my MacBook Pro and it works like a charm... Also note, I believe it's computer hardware issue? I did had the same issue before, and now both my Hackintosh and Windows 7 Parallel are freshly install recently. Also I did upgrade my motherboard on my desktop to one of the high end board, but it still fail, maybe power supply is bad...


Senior Moderator
Dec 12, 2008
Did all those things. still no dice.
I got error 14 when I tried to update a couple years ago. I tried all the steps listed in post #3 and none of them worked. It turned out that it was a corrupt firmware download. Delete the ipsw, connect your phone to the computer and restore in iTunes. It will automatically redownload the firmware. It worked for me.

Edit: just noticed that you said you tried that in post #1. I recommend trying it one more time.