Music from iTunes won't sync with my iPhone

jameela5

New Member
Jun 5, 2010
1
0
0
daniel's way totally worked for me! thankkksss daniel! =) i signed up on this thing just to say thank you to you. lol.
 

GreekGeek

New Member
Jul 6, 2009
2
0
0
Ok;
This is an addon to my post above,

It appears that the problem occurs because there is a glitch in the Music Library on iTunes, at any one time ONCE you sync your iPhone once with lets say 20 songs, and then you add more to your music library it will not sync the new music like it should.

Solution, like I said above, delete every file out of Music Libray, once you delete em all it will say that since you have no files it will sync this to any ipod/iPhone which will mean that you lose any music files you have on your iPhone.

So what you have to do is add your old 20 songs lets say and your new 10 songs to your music library, then it will add 30 for you.
And each time you wana add new music you have to do this, not everyone has to do this just people who are having the music syncing issue, im pretty sure it has something to do with the authorization of the computer/iPhone.

But that works for now,
I had 90 songs, added 50 new ones to my music library, tried to sync and still had 90 after... Even though my music library said 140 songs it was not syncing, so i had to manually delete the songs from music library, got my music deleted off my iPhone, then added 140 songs at once to music library and it added all of em.

BTW, Apple staff doesn't know of a solution for this problem nor do they think it is a problem, their solution is to re-install iTunes which does not work.
The root problem is that Apple's solution for syncing to multiple computers (say a work machine and a home office machine) are, just like Apple, a walled garden. If you want to play outside that garden you need to know a bit more about computers (i.e. not a traditional Mac user more a Linux/Windows user).

That said I had this problem, but it arose not because I messed up my current computers library but because I have two computers I sync to AND I use media monkey to load music (which is SO much better than iTunes but I still have to use the crummy software for apps etc). Anyway behold:

http://www.ismashphone.com/2009/05/how-to-sync-your-iphone-to-multiple-computers.html

:sneaky:

Any time I upgrade my machine at home I just share the hex key from my primary library. I'm sure Apple will one day discover this, Steve Jobs will freak out that someone has escaped the garden (as he always does, that's the culture at Apple our way or your screwed). Just to spite the few people who use this he'll mandate the developers reverse the storage of the hex key to big-endian (reverse order) or encode it some way so people can't easily find it and thereforee leave his walled garden. He's so funny but most control freaks are...
 

raef02

New Member
Jun 23, 2010
1
0
0
What do you mean check all songs on the core iTunes music folder? Are you using a MAC or PC?
I realised that I had to check all of the songs in my core iTunes music folder as if i was selecting them to be played.

When I synched my music from there it worked fine. Bug I think but this seemed to work.
 

iPhoneObsessed

New Member
Bronze
May 9, 2007
77
0
0
Hattiesburg, MS
www.myspace.com
The problem:

I believe the problem arose because of a failed sync. I had cancelled the sync on my iPod, and my iPod thought it was ready to be unplugged, but iTunes froze up when I cancelled the sync and after a few minutes I just killed the iTunes process from the task manager. After restarting iTunes, everything would sync just fine except for my music library. At first my music library would sync about 10 albums from my library (out of hundreds), but after trying a few different sync settings it just stopped syncing music altogether. I tried selecting songs to sync manually, I tried syncing all music, I tried syncing by genre or by artist, but nothing worked.

The solution:

After giving up for a while, I came back later and noticed that there was an exclamation mark next to every song in my library. If I tried playing a song, it would play just fine and the exclamation mark would disappear. I spent the next 15 minutes going through my library playing every song by pressing down + enter repeatedly in the list of all songs. Once I had all exclamation marks cleared, I tried to sync again and this time it worked. All songs now sync correctly. I don't know if this is the cause of anyone else's problems, but it seems that if iTunes marks a file as unplayable then it won't attempt to sync it to your iPod. If you can convince iTunes that the song is playable (and clear the exclamation point) then iTunes will sync it to your iPod.

I hope this helps someone! :eek:k:eek:k
Thank you so much hansede! Your simple solution worked like a charm! I feel like such an idiot... they really need to make that "!" symbol bigger! I don't know if this helps anyone else out, but I would definitely look for the "!" symbol first before removing all songs. :)
 

grasshopper1970

New Member
Oct 21, 2010
1
0
0
Syncing music

Hi Guys. Had the same problem. Needed to delete some music from the iPhone due to lack of space. I am currently packing the "dinosaur" 2G 8GB. Unchecked the song titles in the iTunes music library, synced, but to no avail. EVENTUALLY, I deleted the same unchecked songs within iTunes, synced and presto, it worked! Hope this helps..
 

Ginobaby

New Member
Nov 9, 2010
1
0
0
Im not a pro I barely figured it out. I have looked for answers for 2 days now. I got everything to sync but my music until now.Here is what I did. I hope it works for you. Phone is plugged in to USB port. I have iTunes open and on the page that lists my options I went down midway on the left where it says devices then clicked on my phone then clicked music under that. At the bottom right of this page there is an autofill button. click that. Mine started auto filling then a couple of messages came up on my computer and said my iPhone wouldn't take it. I just cleared off the messages and retried. (I knew there was room because I have 32 GB and I had 8 GB of music.) It is syncing now. (At the bottom center of this page it shows how much memory it will use on your iPhone.)
Please let me know if this worked for anyone else.
 

JNasty

New Member
Feb 9, 2011
3
0
0
Two days ago I plugged in my iPhone and it said I ha to sync it with my iTunes library because it was synced with a different one, so when I clicked yes, it deleted all of my stuff from my library except two songs that I just entered. The next day I figured out how to recover them and get the 980 songs back into my library. I then plugged in my iPhone and went to the music tab. I checked sync music or entire library, then clicked sync in the bottom right hand corner. It started to sync, but only lasted about 2 seconds until it said syncing finished. I knew all of those songs couldn't have been synced in that short of time so I looked on my phone in my iPod and there was still no music in it. I keep trying to sync it but the same thing happens every time. I have a windows xp computer. Does anyone know what I should do or have a solution?
 

JNasty

New Member
Feb 9, 2011
3
0
0
Yeah I made sure they were all checked before I synced them. Thank you anyways though
 

Lon

Evangelist
Gold
Jun 5, 2010
2,946
132
63
Alaska
Unless the boxes beside all the songs you are trying to sync are checked it wont put them on the phone. Make sure they are checked then try to sync the iPhone again. That is all I now to tell you.
I don't believe that is true. You simply have to make your selections under the Music Tab when your iPhone is plugged in. If selecting "Entire Music Library" doesn't work. Try "Selected playlists......" and check all the artists or playlists you want to sync. Try with just a few the first time to see if that works. If "Manually manage music" is checked under your Summary Tab, uncheck it.
 

Ozzie5374

Contributor
Bronze
Nov 7, 2010
422
43
28
Country South Australia
I always have "manually manage" on in the info section. Tick all your tracks and try sign out/sign in and un authorise/ authorise computer. I've had a similar prob with Podcasts- it shows 30 in iTunes but only grey so I can't tick each one just "all Podcasts" - still can't get em? Good luck!


Sent from my iPhone using iCafe app
 

JNasty

New Member
Feb 9, 2011
3
0
0
@Lon- I think I tried that but I can't really remember if I did for sure or not, so I'll try that and see what it does.

@Ozzie- ok i haven't don't that so I'll give it a try when I get home.

Thanks for the suggestions and I'll keep you updated
 

BigLou

New Member
May 11, 2011
1
1
1
I had the same problem, but solved it. In iTunes, highlight all the music in the Music subdirectory under the Library directory. Drag the Music subdirectory down to the Devices directory and drop. All the music will sync now.
 
  • Like
Reactions: justanothergeek

Jason Quigley

New Member
Jun 24, 2011
1
0
1
Manchester, United Kingdom
Same thing happened to me. I tried everything and found that this worked for me:

Uncheck all of the sync boxes on your iTunes (music, appls, movies, ringtones, etc) > SYNC > REMOVE ALL (YES) > Re-sync iPhone with your playlist or whatever you wanted on your phone from iTunes > Proceed to kneeling in admiration to my greatness.

iTunes V. 9.03
iPhone 3GS 16GB V. 9.1.2
Worked for me many thanks, was trying to fix my wifes phone, having to delete her games and all her music was a daunting request. Hey ho it worked many thanks
 

fgrgrwe

New Member
Jun 28, 2011
1
1
1
I had the same problem, but solved it. In iTunes, highlight all the music in the Music subdirectory under the Library directory. Drag the Music subdirectory down to the Devices directory and drop. All the music will sync now.
man do i feel dumb...i had the same problem and ive tried everything for the past 3 days, ive been so fustrated. i just wanted to say THANK YOU SO MUCH! :) i honestly cant believe that was all i had to do... i signed up just so i could thank you!
 
  • Like
Reactions: justanothergeek

Mathew Connelly

Member
Bronze
Jul 13, 2011
116
5
18
If you go to click on the device link from the left-hand side pane within the iTunes main window.

Then go to Music tab and select Sync Music and All music (or Everything - i do not remember this second one) - they have to be both checked. Then sync your device once more, and you will have your music synced to your device.
 

Treasure

New Member
Aug 1, 2011
1
0
1
I am having the same problem with my iPhone 3 G. Didn't have problems a month ago. I have tried all of the suggestions. I keep getting a message at the last step of syncing"this computer is not authorized to download music from iTunes. If you do not authorize you will lose 36 songs." So I authorize and I get a message back that I now have 2 computers authorized out of the 5 allowed. Pushed OK. Then get the message again that the computer is not authorized to download iTunes. I just did the latest update....Authorized and Unauthorized the computer- highlighted the music in the library and moved to the device----NOTHING--ARRG! I am getting the same thing with the IPOD as well. Any other suggestions?
 

Jay Love

New Member
Dec 11, 2011
1
0
1
guys solution is REALLY SIMPLE
1) go to your IPOD SUMMARY
2) scroll down to options
3) check the box "manually manage music"

hope it helps