Not able to access App store


New Member
Nov 23, 2012
My iPhone 3gs is not allowing me to access my App store or the Safari. I stopped and restarted my phone. I went into setting and cleared my history (it deleted fine), my cookie (when I click on that it takes me immediately back to the home screen) and my Cache (it deleted fine). When I click on the Safrai button it takes me directly to my book marks, I then click done to get out of that screen. When I begin to type the web address it send me right back to my home screen. As for the App store, when I click on it it bring up the screen with nothing on it and 3 seconds later it takes me back to the home screen. I can, though, access my Facebook, Mobile banking and my Email so i'm completely confused. Is there something I can do that I haven't tried yet?


Nov 20, 2012
US Midwest
Did both the Safari and App Store issues begin at the same time? Have you tried a hard reset by holding down the Home button and Sleep/Wake button at the same time for 10 to fifteen seconds until the Apple Logo appears then release them? If that doesn't work, try restoring the phone from iTunes using the last back-up you did. Beyond that since the phone is a 3gs, I doubt that it is still in warrantee so Apple or AT&T wont be much help. Good luck, let us know if you find a solution.