Oh Apple, you sneaky bastages!

Woofus

Member
Silver
Kind of bummed about having to wait to get the iPhone 4, but figured that at LEAST I could play with iMovie while I'm waiting.

But NOOOOOOOOOOOO!

It's not compatible with the 3GS.

Damn you Steve Jobs, damn your eyes! Why, oh why must you force me (against my will, mind you) to buy the new iPhone?

Must be the new program they're working on in Cuppertino.

iMindControl

Evil, pure evil!
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
44
Philly
This one I actually understand. I'm surprised they even got it to run so smoothly on an A4!
 

Woofus

Member
Silver
Dude, chill out.
I can't ... I've tried... I know it's a personal attack against me personally!

Somwhere, in a dark meeting room in Cuppertino, CA they were discussing the new app and someone declared, "Hey... lets make this one not compatible with whatever phone Woofus has at the time! That'll teach him! He'll be sobbing like a little girl for weeks over it! Muhahahahahahaha!"

They ain't foolin' nobody!