RoadRunner eMail from iPhone?

Hondamaker

Genius
Gold
May 14, 2007
9,946
655
113
60
Fairborn, Ohio
Seems like none of the port-changing methods work, and the others are a pain in the ass. My idea (in an earlier reply) works well for me, though.
 

Kippen

New Member
Jul 6, 2007
6
0
0
Has anybody tried this?
1. Set up your pop server as normal for Roadrunner: pop-server.ca.rr.com
2. Set up your SMTP server via Gmail: smtp.gmail.com

I haven't tried it yet, but it seems like this should work.
 

Ryukyu

New Member
Bronze
Jun 15, 2007
101
0
0
Has anybody tried this?
1. Set up your pop server as normal for Roadrunner: pop-server.ca.rr.com
2. Set up your SMTP server via Gmail: smtp.gmail.com

I haven't tried it yet, but it seems like this should work.
According to a post over on the Apple discussion boards, it should work.
Here's the main part of the post:

1) SMTP server issue - basically, its hard to know what SMTP server to use since you change location / data provision constantly. This is my current solution:

a. Get a gmail account
b. add the account that you want to use as an account in gmail (see settings)
c. set up the outgoing server on iPhone for gmail settings (under whatever mail account you want in settings -> mail -> account -> outgoing server):
1. pop.gmail.com:587
2. user name (full email address or just gmail user name)
3. pass word
4. turn on outgoing SSL in advanced
5. use password authentication in advanced

Because the account is added in gmail, gmail will not rewrite the from address in your outgoing emails. You cannot currently set up gmail to reforward these messages to some other account due to the way filters work in gmail. (For example, you cannot set up gmail to reforward work emails sent from your iPhone via gmail back to your work address so that they could be saved in a sent box of your work email). Anyway, this solution will work for any email address on any network (wifi or edge).

You may want to set up a filter per below for your work (or whatever) email so that you don't redownload sent messages from your iPhone back to your iPhone.

2) The annoying sent emails in gmail come back to your iPhone. This only applies to iPhone users who are checking gmail on their iPhone. Set up a filter in gmail which deletes all messages from you except those that are written from you and to yourself. This is done by putting xxx@gmail.com in the from field in the filter settings and putting to:(xxx@gmail.com) in the doesn't have field.
 

coop1701

Zealot
Silver
Jun 30, 2007
899
114
43
You can use At&t' outgoing email server. I set it up on My iPhone and can now send emails.

For outgoing server, put in cwmx.com

No Username or Password.

Works like a champ. I had to check the settings in my old razor phone. But I was experiencing the same problems you guys are.

I could rec've, but not send. Now I can do both.
 

coop1701

Zealot
Silver
Jun 30, 2007
899
114
43
Just tried that.



No workee


....sT
I wonder why not... I got it straight off of Cingular's How to set email guide. Works like a champ on my iPhone. Maybe it has something to do with Road Runner, since I'm using Charter.
 

macsimus

New Member
Jul 7, 2007
1
0
0
so sick of this...

i have been having the same problem as everyone else here. My isp is charter communications in los angeles. When connected via wi-fi, i can send and receive emails. Incoming-mail.charter.net and outgoing-smtp.charter.net. When connected to EDGE, sending emails don't work, only receiving. I tried using cwmx.com as outgoing server when using edge and it worked! The only problem now is that when i create a separate pop account for edge, the phone seems to duplicate the account and then always stays with edge settings and makes both accounts exactly the same. This is driving me craZy. Any help would be appre iated.

John
 

mlass

Member
Silver
Jun 19, 2007
678
0
16
try

smtp.att.com

mailhost.att.net

smtp1.attglobal.net

you need a At&t outgoing mail sever

no user name and password

and it is a little slow to send over EDGE

ISPs block to protect from Spammers.

FYI cwmx.com worked for me
 

Ryukyu

New Member
Bronze
Jun 15, 2007
101
0
0
i have been having the same problem as everyone else here. My isp is charter communications in los angeles. When connected via wi-fi, i can send and receive emails. Incoming-mail.charter.net and outgoing-smtp.charter.net. When connected to EDGE, sending emails don't work, only receiving. I tried using cwmx.com as outgoing server when using edge and it worked! The only problem now is that when i create a separate pop account for edge, the phone seems to duplicate the account and then always stays with edge settings and makes both accounts exactly the same. This is driving me craZy. Any help would be appre iated.

John
If you want help, all you have to do is read this thread.
 

rjackb

New Member
Jul 10, 2007
1
0
0
Personal Domain

I found a solution - but it's not exactly simple.

I have a hosting company hosting my personal domain/website, and have just forwarded all of that email to my RR account up to now, and used RR as the catch all to read/send Emails.

So today I switched off the mail forward from my hosting company, and set up my iPhone (and desktop Mac) to use the hosting company's POP server and SMTP server.

Using authentication (username + password) and using port 587, I can hit their outgoing SMTP server from any ISP, including AT&T when using iPhone.

So problem solved (the long way) - although really what I've done is stop using RR for any Email service, and just use them as a pipe for InterNet.

Of course not everyone has their own Domain hosted somewhere - but I'm throwing it out there as a solution that works universally on all ISPs.

Took me 3 days to think of it - but at 4am this morning it all became suddenly clear.... LOL
I have a personal domain as well with email support and all I had to do was set up my iPhone email accounts to use the authenticated SMTP server on my domain's web hosting service for outgoing mail and there is no switching of accounts or forwarding of email involved for either EDGE or WiFi access. In short, all you need is access to an SMTP server, probably authenticated, and you're in businesss. It's too bad that RoadRunner doesn't provide an authenticated SMTP server as that would solve the problem for everyone (but would require reconfiguration of existing RoadRunner accounts unless the authenticated RoadRunner SMTP server was a new server with a different address).

A second alternative is to always turn off WiFi and use EDGE for email and set your SMTP server to cwmx.com (AT&T's EDGE SMTP server). At least where I'm located, EDGE access for email is quite adequate so that's the SMTP server I used until I realized I could use the SMTP server on my web hosting service.

Jack
 

romac13

New Member
Jul 13, 2007
1
0
1
Outgoing Mail for Roadrunner account

You can use At&t' outgoing email server. I set it up on My iPhone and can now send emails.

For outgoing server, put in cwmx.com

No Username or Password.

Works like a champ. I had to check the settings in my old razor phone. But I was experiencing the same problems you guys are.

I could rec've, but not send. Now I can do both.
I tried exactly what you said and it worked. I've been searching for an answer 2 days now. Left off the username and password and the server is typed in like you said. I want to thank you for the information. It does work on a Roadrunner account from the Tampa region.:)
 

vlj9r

New Member
Jul 19, 2007
2
0
0
I set the smtp server to:

smtp-server.tampabay.rr.com:587

Username: your full rr email address like, username@tampabay.rr.com

Password: type it in


With this set up, I'm able to send email from my iPhone using the edge connection and my rr accounts.
 

Hondamaker

Genius
Gold
May 14, 2007
9,946
655
113
60
Fairborn, Ohio
I set the smtp server to:

smtp-server.tampabay.rr.com:587

Username: your full rr email address like, username@tampabay.rr.com

Password: type it in


With this set up, I'm able to send email from my iPhone using the edge connection and my rr accounts.
I have RR in Ohio, and I tried your method, and it won't work for me. I get the dreaded ' Cannot send mail msg. connection the the server has failed.' I just use another RR email acct., call it EDGE, and in the smtp spot, I use cwmx.com:25, no username, no p/w. So if I need to send an email, I use the EDGE acct if I'm not on wi-fi.
 

deac

Member
Bronze
Jun 29, 2007
371
0
16
WOW, fantastic, it finally worked for me also in S.C. (.......@sc.rr.com) using the 587 method above.

One addition. it did not work the first time and i changed the Outing use SSL under Advanced from ON to OFF and then it worked. Seems i had read different opinions as to how it should be set and i ahd it on at first.

This is fantastic.

NoW? Does this same fix work from my iBook on Wifi on the road as I have NEVER been able to send RR mail from the road and they have told me it was not possible because of some kind of spam protection on their part and not recognixing the ip it was coming from.

Thanks so much
 

cdodkin

New Member
Bronze
Jul 2, 2007
305
0
0
SoCal
www.d30-images.com
WOW, fantastic, it finally worked for me also in S.C. (.......@sc.rr.com) using the 587 method above.

One addition. it did not work the first time and i changed the Outing use SSL under Advanced from ON to OFF and then it worked. Seems i had read different opinions as to how it should be set and i ahd it on at first.

This is fantastic.

NoW? Does this same fix work from my iBook on Wifi on the road as I have NEVER been able to send RR mail from the road and they have told me it was not possible because of some kind of spam protection on their part and not recognixing the ip it was coming from.

Thanks so much
Should work for the iBook as well - as it's exactly the same issue that you've been up against.

Damn RR policies!